Enterprise Software

Multiple critical vulnerabilities in Firefox

There are various vulnerabilities in Firefox 1.x and 2.0.x which can lead to cross site scripting, remote system access, and various other attacks.

You can see details at the Mitre CVE site.

CVE-2006-6077
CVE-2007-0008
CVE-2007-0775
CVE-2007-0776
CVE-2007-0777
CVE-2007-0778
CVE-2007-0779
CVE-2007-0780
CVE-2007-0800
CVE-2007-0981
CVE-2007-0995

A reminder, you can find the original CVEs by inserting the correct number in:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0995

The only real fix is to make certain you have updated to versiion 2.0.0.2 or 1.5.0.10 or later.

If you have automatic update on, the fixed versions have probably already been installed. One problem is that even with automatic update, you may need to confirm installation and restart of Firefox even if the new version has been automatically downloaded.

Editor's Picks

Free Newsletters, In your Inbox