Storage optimize

QNAP storage device works after a few snags

Lauren Malhoit decides to replace some of her shop's old NAS devices with some new ones. Here are a few issues she had with the QNAP appliances.

We decided to replace some of our old NAS (Network Attached Storage) devices with some new devices that work a little better and offer some more features.  Using a NAS device would also help us save our SAN storage space for tier-one apps, etc.  We ordered a couple of QNAP Model TS-1279U-RP appliances to do this with the intention of putting one at each of our two sites.

I opened the first box and had a really easy time doing the hardware installation.  Basically, all you have to do is install the hard drives in the shells and plug them in.  Then there is a CD that you can put in to your computer that's on the same subnet which will search for the default IP address of the device.  From here you log in to the Administration console with the default password.  This is when I started running into issues.  There is a place to change the IP addresses to make them static or to utilize the failover/load balancing option.  So I changed the first IP and lost my connection, sending me back to the server room to change the network settings back to default.  Then I'd use the Finder application to locate the device again and try to change the IP a different way.  To make a long story short, I couldn't get the static IPs to take.

At this point I logged a ticket with QNAP support.  I haven't really found any SLAs that they've posted, so I don't know what they are, but it's definitely an interesting support situation.  I waited for a few hours to get some sort of notice that my ticket was logged, but when I didn't hear back, I decided to call.  I was happy to connect with someone on the first try!  The support tech asked me a few questions and then decided to send me a BIOS update for the device, as I had already updated the firmware on my own.  I ran the BIOS update with great hopes, which were quickly dashed when I again lost network connectivity after changing the IP addresses.  I called support back the next day and left a voicemail, yes, a voicemail.  I did the same thing the next day and the next week.  I finally got hold of someone a few days later who decided that the device was DOA and sent me shipping information to exchange it.  He was very helpful, so I don't want to be too negative about it, but it probably shouldn't have taken two weeks of support and unanswered phone calls to discover this.

After boxing up the first device, I opened the second.  I again installed the hard drives and used the finder to locate the device.  I updated the firmware and assigned it static IPs somewhat nervously.  I did a refresh and to my delight, I was still connected!  The web UI was pleasantly responsive and I was even able to configure the load balancing/failover feature with no issues.

The UI has a very clean and modern look to it (see Figures A and B).  The device also has a ton of useful features, such as NFS, iSCSI, Apple Networking, and FTP services.  It integrates somewhat seamlessly, though it can be little sluggish pulling users up, with Active Directory and even works with our trusted domains.  It's simple to configure local users and domain users with proper permissions and their own "private shares."  Connecting to it via FTP, NFS or Windows is also very responsive.  It has a built-in Time Machine feature to back up your Macs on the network (see my blog on configuring Time Machine.    If you're interested in seeing more features, or other products offered, you can visit this site.

Figure A

Figure B

One issue I had once I was working with the good device was the SSL certificate configuration.  I wanted to install and SSL certificate so my FTP over TLS users wouldn't get a warning when they tried to connect.  However, there was no way to generate a certificate request.  The only options shown were to download a self-signed certificate.  I contacted support about this issue as well and they told me that they technically don't support certified authorities such as Thawte or Verisign.  The tech emailed me some stuff on using OpenSSL to extract the necessary components and that worked out all right.  It still seems a little odd to me, though.

After the initial struggle with the first device and the lack of response from support (even though once I got a hold of them they were incredibly helpful), I'm very happy with this device.  It was simple to configure, but if I had any trouble with anything, the admin guide was plainly worded and answered most of my questions.  With the exception of the SSL certificate, which was a minor setback, I'm really enjoying working with the QNAP device.

About

Lauren Malhoit is a VMware vExpert '12, '13 and a member of the EMC Elect. She works as a Solutions Implementation Engineer at Network Storage Inc., where her main concentrations are on VMware, EMC, and Cisco. She has a degree in Computational Mathem...

1 comments
rosege0
rosege0

We use quite a lot of QNAPs at my work and I have a TS-412 at home. I generally find the devices pretty good - speed over iSCSI seems much better than SMB. Just make sure you dont run out of space - I have had some major headaches because of this - why when they are setup they cant reserve a small part of the disk to avoid this is beyond me. Also as you have noticed the support is pretty poor - they also have Skype support but when you ask something its at least a few hours between replies. We are now testing some Drobo's as good support is important to us