Question

  • Creator
    Topic
  • #2208507

    A network question for the bored CCIE…

    Locked

    by mark ·

    The complaint…
    1) Connections from a DS3 to two different T1 connections via MPLS on Century Link’s network passes traffic with no difficulty for things like RDP (remote desktop), the programs are responsive and work as expected
    2) Connections from the same DS3 to a Colo 50Mbps Ethernet circuit functions poorly for RDP (remote desktop) and voice, it does not work as expected.
    3) This is a 10Mbps MPLS from the DS (Split tunnel) and 20M from Colo (Split tunnel).. this should be giving at least 9 Mbps speeds and the two T1s are providing better performance. Here is our DS3 and Ethernet configuration…

    Is there anything mucked up with our config that would cause this?

    IPs have obviously been changed. And I am tired enough to not have bothered keeping them consistent.

    50 Mbps Ethernet
    System image file is “disk0:c7200-is-mz.123-23.bin”

    boot-end-marker
    !
    !
    aaa new-model
    !
    !
    aaa session-id common
    ip subnet-zero
    !
    !
    ip cef
    no ip domain lookup
    ip name-server 8.8.8.8
    !
    !
    class-map match-any best-effort
    match ip precedence 0 1
    match dscp af11
    match dscp cs1
    class-map match-any network-control
    match ip precedence 4 6 7
    match dscp af41
    match dscp cs4
    class-map match-any expedited-forwarding
    match ip precedence 5
    match dscp ef
    class-map match-any assured-forwarding
    match ip precedence 2 3
    match dscp cs6
    match dscp 25
    match dscp af31
    match dscp cs3
    !
    !
    policy-map Template-2
    class expedited-forwarding
    priority percent 80
    set precedence 5
    class network-control
    bandwidth remaining percent 10
    random-detect
    set precedence 7
    class best-effort
    bandwidth remaining percent 10
    random-detect
    set precedence 3
    class class-default
    policy-map Template-2-MPLS
    class class-default
    shape average 20480000
    service-policy Template-2
    !
    !
    !
    !
    interface FastEthernet0/0
    description WAN
    no ip address
    duplex full
    no keepalive
    max-reserved-bandwidth 100
    !
    interface FastEthernet0/0.308
    description DIA VLAN
    bandwidth 30000
    encapsulation dot1Q 308
    ip address 67.67.67.67 255.255.255.252
    no cdp enable
    !
    interface FastEthernet0/0.309
    description MPLS VLAN
    bandwidth 20000
    encapsulation dot1Q 309
    ip address 66.66.66.66 255.255.255.252
    no cdp enable
    service-policy output Template-2-MPLS
    !
    interface FastEthernet1/0
    description LAN PUBLIC
    ip address 67.67.67.67 255.255.255.224
    duplex full
    no keepalive
    max-reserved-bandwidth 100
    service-policy output Template-2
    !
    interface FastEthernet2/0
    description LAN PRIVATE
    ip address 192.168.38.245 255.255.255.0
    duplex full
    no keepalive
    max-reserved-bandwidth 100
    service-policy output Template-2
    !
    router ospf 1
    log-adjacency-changes
    redistribute bgp 65000 metric 1 subnets
    network 192.168.38.0 0.0.0.255 area 0
    !
    router bgp 65000
    no synchronization
    bgp log-neighbor-changes
    network 66.66.66.64 mask 255.255.255.252
    redistribute connected
    redistribute static
    neighbor 66.66.66.65 remote-as 209
    no auto-summary
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 66.66.66.66
    ip route 192.168.39.0 255.255.255.0 192.168.38.1

    ——-
    DS3 config

    ip vrf public
    description DIA VRF
    rd 77.77.77.76:2
    route-target export 77.77.77.76
    route-target import 77.77.77.76
    !
    !
    class-map match-any best-effort
    match ip precedence 0 1
    match dscp af11
    match dscp cs1
    class-map match-any network-control
    match ip precedence 4 6 7
    match dscp af41
    match dscp cs4
    class-map match-any expedited-forwarding
    match ip precedence 5
    match dscp ef
    class-map match-any assured-forwarding
    match ip precedence 2 3
    match dscp cs6
    match dscp 25
    match dscp af31
    match dscp cs3
    !
    !
    policy-map Template-2
    class expedited-forwarding
    priority percent 80
    set precedence 5
    class network-control
    bandwidth remaining percent 10
    random-detect
    set precedence 7
    class best-effort
    bandwidth remaining percent 10
    random-detect
    set precedence 3
    class class-default
    policy-map Template-2-MPLS
    class class-default
    shape average 20000000
    service-policy Template-2
    !
    !
    !
    !
    interface FastEthernet0/0
    ip vrf forwarding public
    ip address 67.128.128.128 255.255.255.224
    ip flow ingress
    duplex full
    !
    interface Serial1/0
    no ip address
    encapsulation frame-relay IETF
    ip route-cache flow
    dsu bandwidth 44184
    framing c-bit
    cablelength 250
    serial restart-delay 0
    frame-relay lmi-type ansi
    max-reserved-bandwidth 100
    !
    interface Serial1/0.16 point-to-point
    description MESH-SPOKE-VPN-VC-16
    bandwidth 10000
    ip vrf sitemap privateroutes
    ip address 88.88.88.87 255.255.255.252
    no cdp enable
    frame-relay interface-dlci 16 IETF
    service-policy output Template-2-MPLS
    !
    interface Serial1/0.18 point-to-point
    description DIA-VC-18
    bandwidth 35000
    ip vrf forwarding public
    ip address 77.77.77.76 255.255.255.252
    ip flow ingress
    no cdp enable
    frame-relay interface-dlci 18 IETF
    !
    interface Serial1/1
    no ip address
    shutdown
    dsu bandwidth 44210
    framing c-bit
    cablelength 10
    serial restart-delay 0
    !
    interface FastEthernet2/0
    ip address 192.168.40.245 255.255.255.0
    ip flow ingress
    ip ospf priority 0
    duplex full
    no keepalive
    max-reserved-bandwidth 100
    service-policy output Template-2
    !
    router ospf 1
    log-adjacency-changes
    redistribute bgp 65000 metric 1 subnets
    network 192.168.40.0 0.0.0.255 area 0
    !
    router bgp 65000
    no synchronization
    bgp router-id 63.234.234.254
    bgp log-neighbor-changes
    network 192.168.40.0
    network 192.168.41.0
    redistribute connected
    redistribute static
    neighbor 88.88.88.88 remote-as 209
    no auto-summary
    !
    address-family vpnv4
    neighbor 77.77.77.76 activate
    neighbor 77.77.77.76 send-community both
    exit-address-family
    !
    address-family ipv4 vrf public
    no auto-summary
    no synchronization
    exit-address-family
    !
    ip classless
    ip route vrf public 0.0.0.0 0.0.0.0 77.77.77.76
    no ip http server
    !
    !
    !

All Answers

  • Author
    Replies
Viewing 1 reply thread