General discussion

Locked

amsn install

By pcbuddy ·
hey folks, just installed fedora 2.0, i ve gone through most posts and tutorials on linux and am kinda stuck if not frustrated...becuase most of the posts assume all goes well which doesnt happen all teh time.all im trying to do is install amsn. and this how am doing it:
downloaded amsn /amsn/amsn-0_93.tar.gz from http://amsn.sourceforge.net/ and saved in /home/shikabwe/src
su
#ls
amsn-0_93.tar.gz
# gzip -d amsn-0_93.tar.gz
#tar xvf amsn-0_93.tar

everything went well here and and could see files extracted etc...
then
#pwd
/home/shikabwe/src
#ls
amsn-0_93 amsn-0_93.tar
#cd amsn-0_93
#./amsn
/usr/bin/env: wish: Permission denied

tried to run;
# wish amsn
bash: wish: command not found
it seems like I dont have the correct tcl/tk according to the tutorials i ve read. what exactly is this? and how do i install it???
can someone tell me where am going wrong????
cant help but feel like going back to spyware/adware infested xp...last resort;-)

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Jaqui In reply to amsn install

root@shikabwe#cd/amsn-0_93
root@shikabwe#./configure
root@shikabwe#make
root@shikabwe#make -install

what you downloaded was sources.
they need to be compiled to use it.

Collapse -

by Jaqui In reply to

in the directory you unpacked the application into.
run "./configure"
then run "make"
then "make -install"

most linux apps are only distributed in sources, not binaries.

binaries are available for a lot of applications from the ditributions website.
./ is important for configure, or it won't know what to do.

check the how-tos for installing from sources. usually a good starting point for learning specific tasks.

Collapse -

by Jaqui In reply to

you only need to su for the make install step
the configure and make can be done as non priveledged user.

as nasty as it sounds, the manual is your friend when learning linux.
http://ldp.org ( linux documentation project )
has the how-tos, man page entries, and various errata on it.
in most languages.

Collapse -

by pcbuddy In reply to amsn install

how do you do that? do you need to download the binary files as well.i ve tried other distros but i ve not been able to install a workable software..you assistance will be highly appreciated.

Back to Linux Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums