Discussions

ASA5520 access to internet

+
0 Votes
Locked

ASA5520 access to internet

ashnil.kumar
hello experts

hello experts


I have a cisco 3750 switch connected to the ASA5520 which is connected to the internet


LAN ----> Catalyst -----> ASA5520 ------> INTERNET


10.1.4.0 ---10.0.0.1 ----10.0.0.2 ------- 203.98.227.3


On my switch I have VLANs configured. From the 10.1.4.0 network, I'm able to ping switch gateway. I can ping insde of ASA .. See my ASA config below. I have allowed http and dns traffic outside but cannot browse internet from the 10.1.4.0 network. I'm able to ping from ASA5520 to all global ips and also all internal ips. Please help.

ASA Version 8.4(2)
!
hostname ciscoasa
enable password xxxxxxxxxx encrypted
passwd xxxxxxxxxx encrypted
names
!
interface GigabitEthernet0/0
nameif outside
security-level 0
ip address 203.98.227.254 255.255.255.0
!
interface GigabitEthernet0/1
nameif inside
security-level 100
ip address 10.0.0.2 255.255.255.252
!
interface GigabitEthernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
object-group icmp-type ICMP_GRP
icmp-object echo
icmp-object echo-reply
icmp-object source-quench
icmp-object time-exceeded
icmp-object traceroute
icmp-object information-reply
icmp-object information-request
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list in_out extended permit tcp 10.1.4.0 255.255.255.224 any eq www
access-list in_out extended permit object-group TCPUDP 10.1.4.0 255.255.255.224 any eq domain
access-list in_out extended permit icmp any any object-group ICMP_GRP
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (any,any) source static any any
access-group in_out in interface inside
route outside 0.0.0.0 0.0.0.0 203.98.227.3 1
route inside 10.1.4.0 255.255.255.224 10.0.0.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics host
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
class class-default
user-statistics accounting
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:dc2ba7a91c9d2244fd109ef7c46e2547
: end
  • +
    0 Votes

    NAT

    NetMan1958

    Is this really the NAT config you are using?
    nat (any,any) source static any any

    +
    0 Votes

    NAT

    ashnil.kumar

    yes, that is the NAT command.

    +
    0 Votes
    NetMan1958

    ciscoasa(config)# no nat (any,any) source static any any
    ciscoasa(config)# object network my-inside-net
    ciscoasa(config-network-object)# subnet 10.1.4.0 255.255.255.224
    ciscoasa(config-network-object)# nat (inside,outside) dynamic interface

    +
    0 Votes
    ashnil.kumar

    Thank you so much... it's working now.. THANK YOU.

    two more questions however.
    I have 1 email server and it has a public ip. How do I send/receive emails using it's public ip ie. I want all traffic coming in/going out from this server (internal ip - 10.10.10.16) to be translated to 203.98.225.9.

    I also want to let the 10.10.10.0 subnet use a pool of global IP address (203.98.225.20 -203.98.225.40 round-robin) when going to internet

    +
    0 Votes
    NetMan1958

    off of your inside interface, then you will need to add a static route to it and the NAT config would look something like this:

    ciscoasa(config)# object network nat-range1
    ciscoasa(config-network-object)# range 203.98.225.20 203.98.225.40
    ciscoasa(config-network-object)# exit
    ciscoasa(config)# object network inside-net
    ciscoasa(config-network-object)# subnet 10.10.10.0 255.255.255.0
    ciscoasa(config-network-object)# nat (inside,outside) dynamic nat-range1 interface

    ciscoasa(config)# object network SMTP_SERVER
    ciscoasa(config-network-object)# host 10.10.10.16
    ciscoasa(config-network-object)# nat (inside,outside) static 203.98.225.9 service tcp smtp smtp

    If the 10.10.10.0 subnet is going to be located on one of the other interfaces, replace "inside" with the name you assign to that interface.

    +
    0 Votes
    ashnil.kumar

    do you also need access list for to allow smtp traffic to come from ASA to the email server

    +
    0 Votes
    NetMan1958

    Yes you will want to create an access-list and apply it to the outside interface:
    access-list out_in extended permit tcp any host 203.98.225.9 eq smtp
    access-group out_in in interface outside

    Also, if the email server is located off of the inside interface instead of one of the other interfaces, add this to the existing access-list:
    access-list in_out extended permit tcp host 10.10.10.16 any eq smtp

    +
    0 Votes
    ashnil.kumar

    Firstly, thank you so much for all your help. Everything is working as expected. You are just awesome.
    For future reference:
    is there any limitation on the number of NAT statements you can have on ASA5520. I would be creating some more networks later and want those network to have their our range of address for translation. Is it possible, for example... 10.5.1.0 to have 10 pulic ips and 10.6.1.0 to have another 10 public ips for NAT

    +
    0 Votes
    NetMan1958

    There probably is some limit on the number of NAT statements but if there is, it must be a really high number as I have ASA devices running a huge number of NAT statements just fine. The one limitation to keep in mind is that you can't static multiple public IP addresses to the same real IP.

  • +
    0 Votes

    NAT

    NetMan1958

    Is this really the NAT config you are using?
    nat (any,any) source static any any

    +
    0 Votes

    NAT

    ashnil.kumar

    yes, that is the NAT command.

    +
    0 Votes
    NetMan1958

    ciscoasa(config)# no nat (any,any) source static any any
    ciscoasa(config)# object network my-inside-net
    ciscoasa(config-network-object)# subnet 10.1.4.0 255.255.255.224
    ciscoasa(config-network-object)# nat (inside,outside) dynamic interface

    +
    0 Votes
    ashnil.kumar

    Thank you so much... it's working now.. THANK YOU.

    two more questions however.
    I have 1 email server and it has a public ip. How do I send/receive emails using it's public ip ie. I want all traffic coming in/going out from this server (internal ip - 10.10.10.16) to be translated to 203.98.225.9.

    I also want to let the 10.10.10.0 subnet use a pool of global IP address (203.98.225.20 -203.98.225.40 round-robin) when going to internet

    +
    0 Votes
    NetMan1958

    off of your inside interface, then you will need to add a static route to it and the NAT config would look something like this:

    ciscoasa(config)# object network nat-range1
    ciscoasa(config-network-object)# range 203.98.225.20 203.98.225.40
    ciscoasa(config-network-object)# exit
    ciscoasa(config)# object network inside-net
    ciscoasa(config-network-object)# subnet 10.10.10.0 255.255.255.0
    ciscoasa(config-network-object)# nat (inside,outside) dynamic nat-range1 interface

    ciscoasa(config)# object network SMTP_SERVER
    ciscoasa(config-network-object)# host 10.10.10.16
    ciscoasa(config-network-object)# nat (inside,outside) static 203.98.225.9 service tcp smtp smtp

    If the 10.10.10.0 subnet is going to be located on one of the other interfaces, replace "inside" with the name you assign to that interface.

    +
    0 Votes
    ashnil.kumar

    do you also need access list for to allow smtp traffic to come from ASA to the email server

    +
    0 Votes
    NetMan1958

    Yes you will want to create an access-list and apply it to the outside interface:
    access-list out_in extended permit tcp any host 203.98.225.9 eq smtp
    access-group out_in in interface outside

    Also, if the email server is located off of the inside interface instead of one of the other interfaces, add this to the existing access-list:
    access-list in_out extended permit tcp host 10.10.10.16 any eq smtp

    +
    0 Votes
    ashnil.kumar

    Firstly, thank you so much for all your help. Everything is working as expected. You are just awesome.
    For future reference:
    is there any limitation on the number of NAT statements you can have on ASA5520. I would be creating some more networks later and want those network to have their our range of address for translation. Is it possible, for example... 10.5.1.0 to have 10 pulic ips and 10.6.1.0 to have another 10 public ips for NAT

    +
    0 Votes
    NetMan1958

    There probably is some limit on the number of NAT statements but if there is, it must be a really high number as I have ASA devices running a huge number of NAT statements just fine. The one limitation to keep in mind is that you can't static multiple public IP addresses to the same real IP.