General discussion

Locked

BIOS does not recognize my SATA drive

By snoop_daniels ·
Dell Dimension 4600
No O/S
Seagate 160Gb Sata HD

I just had my hard-drive crash and decided to buy a SATA drive to replace it. I was careful to make sure the motherboard had SATA compatibility, and it does. I plugged it in today and was going to install windows, but it gave me the message "Primary Sata 0 not found". Bad news. I went throught the bios and found anything that even remotely related to the words "hard drive", but to no avail. I tried installing the RAID drivers at the beginning of the windows installation but it failed to correct the problem as well.
The only thing I can think of is that one of them might be SATA II and the other SATA I (which, consequently, Dell doesn't specify--hang them).
The hard drive is SATA150, which I assume means SATA I. This leads me to the second part of my question: are SATA I mobos and SATA II drives compatible, and why the heck can't people stick to a standard name? Why do some websites/people call it SATA I and others SATA150?
When the old hard drive went out it gave me a similar error message. "Primary IDE 0 not found". I unplugged and plugged it back in and it worked, but I still wasn't able to install Windows; however, all the data was still in tact, and after I connected it with another computer I was able to retrieve it all. It gave every appearance of being in good working order. I read somewhere that the CMOS might have something to do with this. Any ideas?

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CG IT In reply to BIOS does not recognize m ...

well motherboard BIOSs first check for an IDE drive during boot up. With SATA, motherboard mfgs [and this was a couple years ago when SATA first came out]were using the Promise SATA controllers and those were seen by the BIOS as SCSI [mass storage]devices. Further, for the BIOS to actually "see" the SATA drives, you had to create an "array" (just like SCSI] whether you had 1 SATA or 2.

So when you boot up and you view the POSTS screen, you'll go through the standard initialization process and then if the SATA controllers are enabled, [another BIOS option] you'll see the Promise SATA array utility which shows the SATA drives and the array designation [striped or mirrored].

If you don't see the Promise SATA Controller screen to setup your SATA drives in an array, you may have the SATA controller disabled. Baring that, it may be the controller went out. You might check by attaching the drive to the second SATA controller.

Collapse -

by CG IT In reply to

might be the cable went bad as well.

Collapse -

by CG IT In reply to

Dell is like the worst for proprietary software [like BIOSs, drivers, support utilities] so it could very well be their stuff doesn't like the drive.

Collapse -

by dmiles In reply to BIOS does not recognize m ...

you must configure a single drive striped array in the RAID BIOS for the drive to be recognised. Then the RAID drivers must be installed. The win-xp guys can help you with that.

Collapse -

by sgt_shultz In reply to BIOS does not recognize m ...

i feel your pain.
i can't answer your questions about sata names. if me, i would research my drive not found problem at the drive manufacturers website. (if you post back maybe include drive maker, model/part number)
just an aside to cg, promise doesn't sound very proprietary to me. i am happy to hear they have included well known mfg of controllers.
also fyi cmos=bios. so yep, it's got plenty to do with it.
as i see it you have 2 problems. you will need to overcome them in order one at a time
first problem is sata drive is not showing up detected at black screen boot and presumably also not in bios.
perhaps you do need to run utility on drive to make it be a compatible sata drive. see drive mfg website for more info.
perhaps you need to flash your bios to latest version available via dell downloads. this is easy to do.
you may also need to update the firmware in the sata controller via the dell website.
if the drive is not detected after troubleshooting it via dell and drive mfg website, then you might have a bad drive. it is always possible. you can call/email tech support via drive mfg website maybe.
once you get drive detected, you have second problem of getting windows driver for it (btw, 'it' is the sata controller, not the drive, so get the latest sata controller driver for your service tag at the dell website) installed at proper time during the os install so windows can see it.
you do not mention your os so i would think best idea for you is research howto articles for installing windows on sata drive at support.microsoft.com and also dell and also drive mfg's website or did i say that...

if would update my bios to the latest available and look for

Collapse -

by willcomp In reply to BIOS does not recognize m ...

You have a problem with motherboard or cable, not hard disk.

SATA I (SATA 150) drives are compatible with all SATA controllers. Some SATA II (SATA 300 or SATA 3G) drives are not compatible with VIA SATA I controllers but are compatible with Intel ICH SATA controllers (which is what you have).

As for naming, I agree. Would be simpler if actual type was consistently used (SATA 150 or SATA 300). Some are using SATA 3G (3 gigabits per second) for SATA 300 since it sounds sexy.

It is not necessary to load F6 drivers for a single drive with your ICH chipset. Only required for RAID.

Fact that "failed" drive works in another PC should have been a wake up call.

First, swap cable for a known good one.

Next, flash BIOS with latest revision to eliminate BIOS as problem.

Next, check boot sequence in BIOS and ensure that boot hard disk is set to SATA.

Post a comment in your question with results, exact wording of any error messages, and exactly where in boot process they occur.

Dalton

Collapse -

by HAL 9000 Moderator In reply to BIOS does not recognize m ...

When you attempted to install XP did you press the F6 key and load the SATA Drivers from the supplied Floppy or CD that came with the Dell Box?

What is happening here is that while the SATA controller might be being recognized it isn't being configured correctly and is trying to work as a RAID Array so you not only need to install the SATA drivers but configure the SATA Controller as well before you can install Windows.

Col

Collapse -

by snoop_daniels In reply to BIOS does not recognize m ...

I'm not sure how to close a question, so I'll just post an update.

When I came in to work the next day, after playing around with it for hours the day before, I pressed the power button and it just worked. Unfortunately, I have no idea at what point it started working, therefor I can't really say what exactly made it work, but my guess is that something I did in the bios made it work, even though I had already checked the bios. I really don't know what to say.

Collapse -

by pierrejamme In reply to BIOS does not recognize m ...

Lot's of good info above.
You definitely should get the latest BIOS update, currently A12. Dated 9/27/04.
You will be able to see your SATA drive in setup below the IDE drives.

You didn't mention which OS you were trying to install, but most of them say to press F6 if you have SCSI drivers to install and you should have the SATa drivers on a floppy ready to install if that option comes up.
Another trick with a Dell is to clear corrupted NVRAM. In newer Dells and possibly you enter Setup, turn on all three LEDs CAP Lock, Num Lock, and Scroll Lock and the click on <Ctrl> and "E" at the same time. You should hear a beep. Dell Document 146421.

If your computer is different or you don't hear the beep you can clear the CMOS by following you specific Instructions on the motherboard.

Good Luck,
Peter

Collapse -

by pierrejamme In reply to

Whoops, a little Rusty.
that should be Drives:
Floppy
Sata 0
Sata1
Pata 0
Pata 1

Also make sure your jumper is on CS (Cable Select).

Back to Desktop Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Hardware Forums