Question

Locked

Black screen, can't boot up.

By mrgy05 ·
Okay, I've got a custom built PC that I am trying to fix, the MB's mosfet just burnt out so it was sent back RMA and now returned. Prior to the motherboard RMA the PC would not even turn on (fans etc).

Now, the PC will turn on and stay on (fans, etc) but the display shows nothing, as well as no BIOS beeps. The PC can sit forever and obviously not go anywhere, am I looking at a bad PSU? Or possibly the MB is still bad?

Also, if pressure is pushed add on the 24pin ATX power cable connection on the MB, then the PC shuts down completely. Maybe a MB short?

Completely clueless and I don't want to RMA hardware I don't need to, hope someone can help.

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

You either have a short on the board or your power supply cable.

Get another power supply and test that on the board, if it is still the same then it would be the motherboard that is at fault here.

Please post back if you have any more problems or questions.
If this information is useful, please mark as helpful. Thanks.

Collapse -

PS Cable Question

by mrgy05 In reply to You either have a short o ...

I don't have an extra PSU to test with at this moment in time, however, could I assume that the PSU is good because it's supplying power to the PCE slot (GPU fan) all the lights, and all the sys fans

Collapse -

No you can not assume that the PS is good

by OH Smeg In reply to PS Cable Question

While it may be supplying power to those areas you are not sure if it is supplying the correct voltage or Current to run the M'Board and associated components.

If the Voltages are way of it is even possible that a Bad PS has destroyed the M'Board, CPU and RAM.

But first look at the CPU and make sure that it is correctly fitted to the Socket. I have seen numerous times where a Home Builder fits this incorrectly and the same thing happens as you are describing.

What is of more worry is the fact that Electronic Components burnt out previously that indicates a serious fault that needs rectifying before you proceed any further.

Col

Collapse -

My experience

by thedrummer2006 In reply to You either have a short o ...

I had this one time and it was a bad CPU.

Collapse -

Seen this before

by mjd420nova In reply to Black screen, can't boot ...

One of the biggest problems I've seen on home brew units is the shorting of the power supply. Remove the motherboard and look at the chassis. Replace the standoffs that the MOBO mounts to with nylon or plastic ones. Any one of them can short the power supply and stop the POST.

Collapse -

Hmm

by mrgy05 In reply to Seen this before

My case is 100% acrylic, could the standoffs still have an effect?

Collapse -

Probably not the fault then

by mjd420nova In reply to Hmm

The only other reason for it not starting would be that the video card is faulty or not getting enough power. The video BIOS has to start first, that's the first display you should see. Once it starts, it will then send the signal to the system BIOS telling it where to send the display, then you'll see the system BIOS on the display and it should count the memory and so on. Some of the newer video cards also require a direct power connection from the power supply, without that it would be unable to draw enough power from the system board through the board edge connection. The other fault could be a bad capacitor on the system board that would short the power supply. A multimeter would give you a better clue. When pressure is applied and it shuts down, that's the clue that the fault may lie in a bad, intermittent or cold solder joint on the power supply connector.

Back to Windows Forum
8 total posts (Page 1 of 1)  

Operating Systems Forums