Question

Locked

Cannot Access USB External Drive

By khalilanasir ·
My C: drive recently crashed. I was getting OS not found following an audio edit i was doing on an audio production program. I bought a new HD, installed XP sp2 on the new drive, bought a usb enclosure for the old system drive with the intent of moving all my important files from that drive to new locations, since I figured the old drive is just plain trashed. when i plugged the old enclosed drive in to the pc, windows detects a mass storage device, but it doesn't show up on My Computer... Disk Management sees it, but somehow it still won't show up on My Computer so I can access the files. Also, if the usb is powered on when I boot the pc, it won't even boot. once I turn the drive enclosure off, everything is normal. I remember when the pc crashed i tried repairing it, and it said that it couldn't find the master boot record. The drive is a Quantum Fireball Lct 10 20... I'm at my wits end on how to access this drive! I tried Using GETDATABACK program, and it recognizes the drive but I get LBA access errors and the program crashes. Any ideas? I have very valuable data on this drive I must recover!

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Could be Bad Sectors on the drive

by Jacky Howe In reply to Cannot Access USB Externa ...

Open My Computer, Right click the Removable drive, Go to Properties, Tools. Run Error Checking and Scan for errors and fix them. If that does'nt work try this.
<br><br>
Click Start and in the Run box type in cmd and press Enter.
<br>
At the command prompt type in chkdsk <i>DriveLetter</i>:/r
<br><br>
Use the Drive maufacturers Testning softwate, Seagate "Seatools"
<br>
http://www.seagate.com/support/seatools
<br><br>
<i>Keep us informed as to your progress if you require further assistance.</i>
<br><br>
<i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.
</i>

Collapse -

Just realised that its not showing

by Jacky Howe In reply to Could be Bad Sectors on t ...

in My Computer. You had better try this first along with OH Smegs suggestion. I think that the PC wouldn't boot was probably because it was trying to boot from the external. Write down all fixed Disk and CD/DVD drive letters so as not to delete them. DO NOT delete any of the fixed hard disk drives or CD/DVD optical drives registry values.
<br><br>
1. Login with Administrative privileges.
<br>
2. Disconnect all USB or FireWire storage devices.
<br>
3. Open Registry Editor by typing regedt32 in the Run box and navigate to the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
<br>
4. Under HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices there will be registry keys with the name that resembles the format of \DosDevice\X: where X can be any alphabet letter which corresponding to your physical system drive letter.
<br>
5. Delete all possible USB drives, FireWire drives and external drives which have a drive letter.
<br>
<b>DO NOT delete any of the fixed Hard Disk Drives or CD/DVD optical drives registry values.</b>
<br>
Exclude \DosDevice\A: which normally reserved for floppy disk drives.
<br><br>
<i>Keep us informed as to your progress if you require further assistance.</i>
<br><br>
<i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.
</i>

Collapse -

Just realised that its not showing

by khalilanasir In reply to Just realised that its no ...

Ok, I deleted the registry keys of all usb connected drive specifications. However, the external drive in question was not specified there. Nevertheless, I did as you instructed. Of course, I cannot utilise OH's advice, because the prerequisite is that i must be able to access the drive. the active light stays on, but nothing happens. I'll try to reboot with only the usb drive in question connected and see what happens.
Thanks so much for your help. I'll post what happens next.
Cheers,
Khalil

Collapse -

After you did

by Jacky Howe In reply to Just realised that its no ...

the Registry fix and plugged it in did you get allocated a Drive letter. If so then run chkdsk. Have you tried plugging into the rear USB ports. You could also put the drive back in the PC as it was before and try this.
<br><br>
Insert your XP CD and when you see ?Press any key to boot from CD? press a key. Now wait for the XP installer to finish loading up and you will be presented with the option to press R to Repair.
<br><br>
Press R.
The next screen will ask you which Windows? installation you would like to log on to. Normally the following will be listed:
<br><br>
1: C:\WINDOWS
<br><br>
Press 1, then Enter to continue.
<br><br>
You may now be asked for the Administrator password. If you know this type it and press Enter. If you don't know the Administrators password it may be blank. Just press Enter or type your username and password.
<br><br>
At the command prompt type:
<br><br>
fixmbr and press Enter
<br><br>
fixboot and press Enter
<br><br>
Wait until you are returned to the Recovery Console.
<br>
Once you are back to the Recovery Console remove the XP CD and restart your PC.
<br><br>
<i>Keep us informed as to your progress if you require further assistance.</i>
<br><br>
<i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.
</i>

Collapse -

The Drive here needs to be set to Master

by OH Smeg In reply to Cannot Access USB Externa ...

Before you install it into the USB Caddy. If it is set to CS Cable Select the USB to IDE Interface incorrectly identifies the HDD.

You do not need any Data Recovery applications to copy your Data off the HDD as it is freely available when you open the drive but there are some exceptions. If you where using XP Pro and had enabled EFS Encrypted File System and you do not have a backup of the Encryption Key your data is toast forget about it you'll not see it again without spending lots of money at a Data Recovery House.

If you where using a Password on the OS that required you to enter it before Windows would open you need to Take Ownership of the Files by following the directions here

http://tinyurl.com/3aw7

The important part is this but the full text is available at the M$ Web Site

How to take ownership of a folder
Note You must be logged on to the computer with an account that has administrative credentials. If you are running Microsoft Windows XP Home Edition, you must start the computer in safe mode, and then log on with an account that has Administrative rights to have access to the Security tab.

If you are using Windows XP Professional, you must disable Simple File Sharing. By default, Windows XP Professional uses Simple File sharing when it is not joined to a domain.

For additional information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:
307874 (http://support.microsoft.com/kb/307874/) How to disable simplified sharing and set permissions on a shared folder in Windows XP
To take ownership of a folder, follow these steps: 1. Right-click the folder that you want to take ownership of, and then click Properties.
2. Click the Security tab, and then click OK on the Security message (if one appears).
3. Click Advanced, and then click the Owner tab.
4. In the Name list, click your user name, or click Administrator if you are logged in as Administrator, or click the Administrators group. If you want to take ownership of the contents of that folder, select the Replace owner on subcontainers and objects check box.
5. Click OK, and then click Yes when you receive the following message:
You do not have permission to read the contents of directory folder name. Do you want to replace the directory permissions with permissions granting you Full Control?

All permissions will be replaced if you press Yes.
Note folder name is the name of the folder that you want to take ownership of.
6. Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.

Back to the top

How to take ownership of a file
Note You must be logged on to the computer with an account that has administrative credentials.

To take ownership of a file, follow these steps: 1. Right-click the file that you want to take ownership of, and then click Properties.
2. Click the Security tab, and then click OK on the Security message (if one appears).
3. Click Advanced, and then click the Owner tab.
4. In the Name list, click Administrator, or click the Administrators group, and then click OK.

The administrator or the Administrators group now owns the file. To change the permissions on the files and folders under this folder, go to step 5.
5. Click Add.
6. In the Enter the object names to select (examples) list, type the user or group account that you want to give access to the file. For example, type Administrator.
7. Click OK.
8. In the Group or user names list, click the account that you want, and then select the check boxes of the permissions that you want to assign that user.
9. When you are finished assigning permissions, click OK.



Hope this is of assistance

Col

Collapse -

The Drive here needs to be set to Master

by khalilanasir In reply to The Drive here needs to b ...

Thanks for your very helpful reply, OH Smeg. Yes, I had it set while in the cpu as CS, but as it is on a usb bus now, I figured I'd need it to be set to master. As to the other instructions you gave me, I need to first be able to get access to the drive. no drive letter is assigned, even though it is recognised in device manager, and appears to be working, so I know it isn't a hardware or connection issue. I'm almost sure it's either bad sectors or damaged mbr... I suppose, however, I need to get past that in order to enact the priveleges. Is there another way? Also, since I'm using xp pro, and the access was via password, I know i'll need to use these instructions. as far as encrypted file system, i didn't set it up that way. is there a way i could have done that unknowingly? What setting enables this, or would I know if I did that upon install?
Thanks again for your help! I'll keep you all posted.
Cheers,
Khalil

Collapse -

Do NOT set it to Master..........

by ThumbsUp2 In reply to The Drive here needs to b ...

The Master setting is only used when it's connected to the IDE controler. When it's in an elclosure, you do not set it that way or the system will not be able to recognize it.

Collapse -

Do NOT set it to Master..........

by khalilanasir In reply to Do NOT set it to Master.. ...

Thanks for your reply ThumbsUp2...

When I had it set for CAble Select, as I did while it was connected to the CPU, the usb wouldn't recognise it either. If not master, or Cable Select, then what? setting it for slave doesn't seem right, or does it? any insight will be really helpful! Thanks!

Khalil

Collapse -

Try NO jumper at all.... <nt>

by ThumbsUp2 In reply to Do NOT set it to Master.. ...
Collapse -

Every 3.5 Inch IDE Drive that

by OH Smeg In reply to Do NOT set it to Master.. ...

I've ever fitted to a USB Enclosure required the drive to be set to Master. They wouldn't work if set to anything else or with the Jumper removed completely.

The 5 I have in a safe here are set to Master and work perfectly in every USB Enclosure that I use as well as the hundreds that I have sold to clients over the years so Master is the right setting for every USB Enclosure that I have ever used. Even the 2.5 Inch IDE's need the jumper refitted and set to Master to work in these enclosures.

Col

Back to Hardware Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Hardware Forums