Question

Locked

Can't connect HP Procurve 2848 SFP to Cisco 3548XL GBIC 1000SX

By GerryC ·
Hi all,

I am trying to uplink an HP Procurve 2848 switch with a Cisco Catalyst 3548XL using an SFP on the Procurve and the GBIC fiber module on the Cisco. I have updated the firmware on the Cisco to 12.5(WC17) but I am not sure of the correct configuration. not have any VLANs configured, just the default VLAN1 on both devices.

CISCO Catalyst Config
interface GigabitEthernet0/2
flowcontrol
no negotiation auto
switchport trunk encapsulation dot1q
switchport mode trunk
no cdp enable

HP PROCURVE Config
interface 48
name "Cisco Uplink"
flow-control

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

show interface

by NetMan1958 In reply to Can't connect HP Procurve ...

run the command:
"show interface GigabitEthernet0/2"
on the Cisco and post the output.

Collapse -

Interface Results

by GerryC In reply to show interface

Hi NetMan1958,

Here are the results:

Cabinet1_48C#sho int g0/2
GigabitEthernet0/2 is up, line protocol is up
Hardware is Gigabit Ethernet, address is 0007.50f4.86b2 (bia 0007.50f4.86b2)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not set
Auto-duplex (Full), 1000Mb/s, media type is SX
output flow-control is on, input flow-control is on
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:14, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 4000 bits/sec, 4 packets/sec
5 minute output rate 12000 bits/sec, 10 packets/sec
4526 packets input, 1195713 bytes, 0 no buffer
Received 284 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 155 multicast, 0 pause input
8293 packets output, 1300157 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

The issue I am having is that PCs connected to the HP can ping but not browse the network. Here is the error message I am receiving on the HP Procurve "Status Page":

"Excessive CRC/Alignment Errors on port 48"

These are occurring every minute or so.

Thanks in advance.

Collapse -

Set the...

by cmiller5400 In reply to Interface Results

Set the speed/duplex hard in the configuration to 1000 and duplex to full on both the Cisco and HP switches. This may be an auto-negotiation error (sometimes mixed vendor switches don't play well with each other concerning auto-negotiation)...

Collapse -

Re: Set the..

by GerryC In reply to Set the...

Thanks for the suggestion.
I just posted the configs. I think I have the speed/duplex forced now but still same behavior.

Also not sure if makes a difference but using a compatible w/OEM #J4858C SFP module in HP.

Collapse -

HP Interface stats

by GerryC In reply to show interface

NetMan,

Here are the stats from the Procurve side.

Link Status : Up
Totals (Since boot or last clear) :
Bytes Rx : 81,834,773 Bytes Tx : 2,974,426,593
Unicast Rx : 1,071,298 Unicast Tx : 2,032,033
Bcast/Mcast Rx : 23,409 Bcast/Mcast Tx : 16,268
Errors (Since boot or last clear) :
FCS Rx : 497 Drops Rx : 0
Alignment Rx : 0 Collisions Tx : 0
Runts Rx : 0 Late Colln Tx : 0
Giants Rx : 0 Excessive Colln : 0
Total Rx Errors : 499 Deferred Tx : 0
Rates (5 minute weighted average) :
Total Rx (bps) : 5011864 Total Tx (bps) : 5004808
Unicast Rx (Pkts/sec) : 0 Unicast Tx (Pkts/sec) : 0
B/Mcast Rx (Pkts/sec) : 6 B/Mcast Tx (Pkts/sec) : 0
Utilization Rx : 00.50 % Utilization Tx : 00.50 %

Looks like there are only RX errors.

Thanks.

Collapse -

Try the suggestion above

by NetMan1958 In reply to HP Interface stats

about hard coding the duplex to full and the speed to 1000 on both switches and let us know if the errors go away.

Collapse -

Another thought

by NetMan1958 In reply to Can't connect HP Procurve ...

Is what you posted the complete config for interface 48 on the ProCurve? If not, can you post the entire config? If you haven't already done so, you will need to configure that port as a trunk so that it will pass traffic for all vlans.

Collapse -

Re: Another thought

by GerryC In reply to Another thought

Just to be sure I upgraded the switch software to I.10.77.

Here is the complete config on the Procurve now:
Running configuration:

; J4904A Configuration Editor; Created on release #I.10.77

hostname "ProCurve Switch 2848"
snmp-server contact "NA"
snmp-server location "NA"
interface 48
name "Cisco Uplink"
flow-control
speed-duplex 1000-full
exit
ip default-gateway XX.XX.XX.XX
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-48
ip address XX.XX.XX.XX XX.XX.XX.XX
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
spanning-tree
password manager

*Note sure how to force trunking on Procurve

So far I can surf the web through the switch but if I attempt to access network shares it either takes forever or fails altogether.

Here is also the config for the 3548XL that was upgraded to the latest CatOS.

interface GigabitEthernet0/2
flowcontrol
no negotiation auto
switchport trunk encapsulation dot1q
switchport mode trunk
no cdp enable

Thanks again.

Collapse -

Take a look at this

by NetMan1958 In reply to Re: Another thought

http://ftp.hp.com/pub/networking/software/Mgmt-Oct2005-59906023-Chap12.pdf

You want to force it to trunk and not LACP.
Also, on the Cisco, run "sh vlan br" and post the results.

Collapse -

Re: Take a look at this

by GerryC In reply to Take a look at this

Here are the results of "sh vlan br"

Cabinet1_48C# sh vlan br
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4,
Fa0/5, Fa0/6, Fa0/7, Fa0/8,
Fa0/9, Fa0/10, Fa0/11, Fa0/12,
Fa0/13, Fa0/14, Fa0/15, Fa0/16,
Fa0/17, Fa0/18, Fa0/19, Fa0/20,
Fa0/21, Fa0/22, Fa0/23, Fa0/24,
Fa0/25, Fa0/26, Fa0/27, Fa0/28,
Fa0/29, Fa0/30, Fa0/31, Fa0/32,
Fa0/33, Fa0/34, Fa0/35, Fa0/36,
Fa0/37, Fa0/38, Fa0/39, Fa0/40,
Fa0/41, Fa0/42, Fa0/43, Fa0/44,
Fa0/45, Fa0/46, Fa0/47, Fa0/48
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

Thanks for the link I will take a look now.

Back to Networks Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Hardware Forums