Question

Locked

cant find audio driver after downgrading laptop

By pings84 ·
hi forumers....
as the title says...
i have downgraded a laptop of a fren from win7 to xp as requested by my fren...after downgrade, i went in da manufacturer's support page n downloaded all the necessary drivers for win xp...
all the drivers can be installed with not much hassle but 1....
the audio driver.....

the error msg is 'we can't find HD audio devide'
i've tried conexant, realtek but to no avail.....*sigh
im runnin out of ideas....

i've tried da program Unknown Device Identifier 7.00 to try identify the manufacturer of the audio but the only lead i have is >>
(Chip: ATI Technologies SB600 High Definition Audio Controller)

which leads me to nowhr....T.T ~ SOBSOB!

the laptop brand is Asus K50AB series....
pls help me....T.T

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Should probably be the Realtek driver.

by seanferd In reply to cant find audio driver af ...

Is it an XP driver? If not, you will have problems here.

You can look up the specs for you exact laptop and find out exactly what the Realtek part name is. Then, find the driver at Asus or, failing that, see if Realtek has the right driver for XP.

edit: I'm only seeing a VIA driver here, but it may be different for your region, or rather, the region from which the notebook came.
http://support.asus.com/download/download.aspx?modelname=K50AB&SLanguage=en-us

But you may need this as well:
http://support.microsoft.com/kb/888111
unless your XP is already at SP3.

Collapse -

hmmmm

by pings84 In reply to Should probably be the Re ...

hi seanferd....
tx 4 da reply...

i've checked n re-checked...
i did download da drivers for xp...
n i did pick the right region for me..
im from malaysia btw....
for xp thrs 2 files in the option...

1 is da hot fix(if im not mistaken) n da other is via hd audio drivers....

i installed da hot fix n no problem but da via driver wont install as it said da installer cant detect the hd audio in the laptop...but why is the driver in the xp section that if its not for xp?? weird...

i've check the laptop spec in asus's page but they didnt mention anythin bout da audio's manufacturer...hmmm

i've tried realtek for xp, no sound came out
*sigh.....

my xp is sp2....^^;;

tx again 4 da help, seanferd...
will try da link dat u giv me....

Collapse -

ATI / AMD Driver

by TheChas In reply to cant find audio driver af ...

The ATI SB600 looks like it may be a key here. As the specifications call out an AMD chip-set with ATI video, it would make sense that the audio is part of the AMD chip-set.

When I look at the download page for this model, I get a VIA driver and a Microsoft Update for the audio system. There is also an "others" which lists an ATI SM Buss driver which I think you need to install prior to installing the audio driver.

I did not look up the chip-set at the AMD web site. That might provide additional information.

Chas

Collapse -

hmmm...

by pings84 In reply to ATI / AMD Driver

hi Chas
tx for the reply....

i did installed the sm bus driver...
but still nuthin happen n i still cant detect and hd audio device....

Collapse -

audio drivers

by asuvlumuzi In reply to cant find audio driver af ...

if you are using xp service pack 2, then you need to download an update that make xp 'see' your hd drivers before you can install them. the update is available freely from microsoft and might be titled 'kb888111xpsp2'.
After installing the update, you can then install drivers from VIA
good luck

Collapse -

audio drivers

by pings84 In reply to audio drivers

hi asuvlumuzi@...
tx for da reply...

i alrdy download the update n installed it but it still cannot detect hd audio device...:(

Collapse -

As this is a VIA Device

by OH Smeg In reply to cant find audio driver af ...

Your problem here is most likely related to the Install Sequence.

I have found previously when installing XP it's best to allow XP to install then the Audio Driver after XP loads. You can then set about installing any extra Drivers required BUT you should install these before connecting to the Windows Update Servers where those 2 applications get installed before starting the remainder of the Update Process.

I'm not sure with the VIA devices but with Realtech you need to install the Sound Driver before connecting to the Update Servers or it doesn't work.

Of course you could always make a Slipstreamed Image for this system and include the Audio Drivers in that. You can use nLite available free here

http://www.nliteos.com/download.html

Just make sure that you read the directions listed under Guides on their Web Site here

http://www.nliteos.com/guide/

This makes life a lot easier.

Col

Back to Hardware Forum
9 total posts (Page 1 of 1)  

Hardware Forums