General discussion

Locked

Changes to .HTM property not saved by VI

By NRGeti ·
I am new to Visual Interdev and need some help on editing .HTM files.

My environment is Windows XP SP1a on which I installed Visual Studio v6.0 which has VI.

I have set up a project and obtained the DEFAULT.HTM file using the Site Diagram control as well as adding some pages to this control. Changes to text on the pages are saved but any change I make to the Type or Home check boxes in the Appearance tab of the Property Sheet are not saved.

Specifically, I check any of the boxes and do a File/Save, then File/Close. When I open the file again and look at the boxes, my changes are gone and the edits have reverted back to the original.

I have tried setting permissions in IIS in every combination I can think of and nothing helps.
Can anyone help?

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Changes to .HTM property not saved by VI

by Thamer In reply to Changes to .HTM property ...

My guess is the you are using VI to edit and then let it interacts with IIS to "save" or "send" the changes.

If that so,... my advise to you would be ,... IIS IS PURE [beeeeeeeeeeeeeeeeeeep]!. Do not by any means use those functions, they do notwork. VI is a nice editor thu, so if you don't use the project-functions you'll be fine.

Collapse -

Changes to .HTM property not saved by VI

by NRGeti In reply to Changes to .HTM property ...

I am following a textbook published by Wrox in order to learn VI and the examples work in the book but not on my PC.

The first chapter of the book walks through the installation of VI and IIS and states that IIS is required to run VI. So I don't see how to avoid using the VI "Save" functions.

Collapse -

Changes to .HTM property not saved by VI

by MadestroITSolutions In reply to Changes to .HTM property ...

This is a known issue for Interdev. If It is what I think it is, then it deals with you not being able to change the home page.

To make some other page the home page do this:

- In the site diagram, remove the home page (right-click it and choose delete).
- Delete Default.htm from the Visual InterDev project by right-clicking on the file in the Project Explorer window and choosing Delete.
- If the file Default.asp already exists, then drag it from the Project Explorer window onto the site diagram (it should come up as the home page). Save the changes at this time.
- Right-click the site diagram and select Add Home Page. Do not save at this time.
- Right-click the home page in the site diagram and select Property Pages. Change the URL field to Default.asp.
Save your changes. If Default.asp is not in the project already, it will be added automatically.


Good Luck!

Collapse -

Changes to .HTM property not saved by VI

by NRGeti In reply to Changes to .HTM property ...

Please clarify how I can determine the home page so I can delete it. If you mean "default.htm" that is installed when I install IIS then the snap-in will not let me delete it.

Also the VI project will not permit me to elete "default.htm" from the Project list.

Furthermore the VI project disables the Add Home Page option so I cannot click on it.

What do you mean by the URL field? Are you talking about the "Redirection to a URL" radio button? If you are, then which checkbox below do I check and what do I enter in the http:// field?

I am running Master mode in VI which builds the web page in localhost as well as a local copy somewhere else on my drive.

On top of all that I cannot delete the Master folder so I can start over. It keeps insisting that there is another person or application holding the file and I should close them. But there is no other process open.

Collapse -

Changes to .HTM property not saved by VI

by MadestroITSolutions In reply to Changes to .HTM property ...

- First of all, you dont have to reject an answer if you dont understand it, just reply to my e-mail and I will help you out... now you have hurt my rating...
Second, if you do what I suggested, YOU WILL BE ABLE TO DELETE the home page! (at least try what I suggest before you comment on it)
Third, of course it is going to tell you the file is locked, BECAUSE INTERDEV LOCKS THE FILES IN ORDER TO MAINTAIN CONSISTANCY WITH THE MASTER WEB. If you delete files, you delete them trhough the interface, and if it is the home page you want to change, do what I suggested on top.

I think I deserve the points for the aggravation..... considering I risk being rejected again on this question and hurting my rating even more.....

Good luck, andif you have questions on this one, PLEASE E-MAIL ME: juanja01@optonline.net

Good Luck!

Collapse -

Changes to .HTM property not saved by VI

by NRGeti In reply to Changes to .HTM property ...

Poster rated this answer

Collapse -

Changes to .HTM property not saved by VI

by Thamer In reply to Changes to .HTM property ...

Okay,... just make a "Virtual directory" in IIS and then create your .asp pages in. Open Interdev and drag the files in to it. It will be placed in the "misc -files" and not in a project, ... that's the only I know where you can be shure that the changes you make .... are saved.

Take care.

Collapse -

Changes to .HTM property not saved by VI

by NRGeti In reply to Changes to .HTM property ...

I signed up for a technical support session from Microsoft and he was able to reproduce my problem. This meant a refund on the call.

It turns out that VI does not initialize the PagNavBar controls correctly on .htm pages when they are first opened for editing.

The work-around is to highlight the PageNavBar control and delete it by hitting the Delete key. Then drag a new on into the same position from the Toolbox/Design-Time Controls in the left panel of the Visual Interdev editor.

Nowany edits to the property sheet options will be saved correctly.

Collapse -

Changes to .HTM property not saved by VI

by NRGeti In reply to Changes to .HTM property ...

This question was closed by the author

Back to Web Development Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums