Question

Locked

Cisco 851W FE4 not getting IP from dhcp

By joebloggs1010101 ·
Hi
I've got a Cisco 851W router which refuses to pick up an IP address from my ISP, any chance someone could take a look at the config and let me know where i'm going wrong.
Cheers

Here is the error given when i test the connection and also the running config.

No IP address for the interface has been obtained.
The interface is configured to obtain an IP address through DHCP.
The remote end may not be configured with a DHCP server or the DHCP pool may be empty.

Building configuration...

Current configuration : 2152 bytes
!
! Last configuration change at 10:19:32 PCTime Thu Oct 22 2009 by sflynn
! NVRAM config last updated at 23:27:12 PCTime Wed Oct 21 2009
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 $1$aU25$bJAt0II714aTDoAzwSRxM.
!
no aaa new-model
clock timezone PCTime 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
!
!
dot11 syslog
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.0.1 10.10.10.1
ip dhcp excluded-address 10.10.11.0 10.10.255.254
!
ip dhcp pool HAL-IP
import all
network 10.10.0.0 255.255.0.0
dns-server 10.10.10.1
default-router 10.10.10.1
!
!
ip cef
ip inspect name fw tcp
ip name-server 89.101.160.4
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description $ETH-WAN$
ip address dhcp client-id FastEthernet4
ip broadcast-address 0.0.0.0
ip inspect fw out
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
ip broadcast-address 0.0.0.0
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
ip address 10.10.10.1 255.255.255.0
ip broadcast-address 0.0.0.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet4 overload
!
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 100 remark SDM_ACL Category=128
access-list 100 permit ip host 255.255.255.255 any
access-list 100 permit ip 127.0.0.0 0.255.255.255 any
access-list 101 remark SDM_ACL Category=128
access-list 101 permit ip host 255.255.255.255 any
access-list 101 permit ip 127.0.0.0 0.255.255.255 any
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

DHCP Pool

by Edgar_Collins In reply to Cisco 851W FE4 not gettin ...

Yours:
ip dhcp pool HAL-IP
import all
network 10.10.0.0 255.255.0.0
dns-server 10.10.10.1
default-router 10.10.10.1

Should Be:
ip dhcp pool HAL-IP
import all
network 10.10.10.0 255.255.0.0
dns-server 10.10.10.1
default-router 10.10.10.1

Collapse -

A couple of points

by NetMan1958 In reply to Cisco 851W FE4 not gettin ...

You have interface FastEthernet4 configured with "ip inspect fw out" but no access-list is applied to that interface. Also, you are only inspecting TCP traffic with that firewall config: "ip inspect name fw tcp".

First, remove the firewall from the interface ("no ip inspect fw out") and see if that helps.

If you still don't get an IP try this:
"terminal monitor"
"debug dhcp detail"
then shut interface fastethernet4 and reopen:
"conf t"
"int fa4"
"shut"
"no shut"
Press CTRL + Z
If you get any output from the debug post it back here.
Turn off debugging:
"undebug all"

Collapse -

Debug

by joebloggs1010101 In reply to A couple of points

Got "DHCP: QScan: Timed out selectying state debug dhcp %Unknown DHCP problem. No allocation possible"
Any help would be great thanks

Collapse -

Is this Cable, DSL, or something else?

by NetMan1958 In reply to Debug

If it's cable or DSL, try connecting a computer directly to the modem and see if it get's an IP Address.

Back to Networks Forum
5 total posts (Page 1 of 1)  

Hardware Forums