General discussion

Locked

Cisco 851W what should be easy..

By LisaNels ·
After working on this router for about a week now, I've got everything working on it (I think) with the exception of the link between the internal network, and the Internet.
I'm very new to This type of device, and have used the CLI and also Cisco's CPP. So I thought I'd work on it until it drove me crazy... thus my post!

Setup: House network on 192.168.5.0 using both wired and wireless clients. PPPoE connection to Qwest.net.

The DHCP I have running seems to work, but I do not get any info that comes from the connection to Qwest. (Nameservers) Only what I put in the DHCP setup. I also do not know how to check the DSL connection other than seeing a valid IP address for the Dialer interface.

I can ping between the wired and wireless devices on the internal network. I'm pasting my whole config with the passwords changed for security.

Any help would be greatly appreciated. I've learned a lot in the last week, but this part has got me stumped.

Thanks,
Lisa

Using 2952 out of 131072 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco851w
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-224790426
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-224790426
revocation-check none
rsakeypair TP-self-signed-224720426
!
!
crypto pki certificate chain TP-self-signed-22470426
certificate self-signed 01 nvram:IOS-Self-Sig#A.cer
dot11 syslog
!
dot11 ssid Lisa
vlan 1
authentication open
guest-mode
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.5.1 192.168.5.239
!
ip dhcp pool sdm-pool
import all
network 192.168.5.0 255.255.255.0
default-router 192.168.5.1
dns-server 2.3.4.5
lease 0 0 10
!
!
ip cef
no ip domain lookup
ip domain name .local
!
!
!
username lisa privilege 15 secret 5 $1$Zt/y19UTIM1
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description $ETH-WAN$
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dot11Radio0
no ip address
!
ssid Lisa
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
no ip address
ip tcp adjust-mss 1452
bridge-group 1
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname flbl1017@qwest.net
ppp chap password 0 baPjB74Bgw
!
interface BVI1
ip address 192.168.5.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1412
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 remark INSIDE_IF=BVI1
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.5.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 23 permit any
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end

Cisco851w#

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Your WAN IP?

by NetMan1958 In reply to Cisco 851W what should be ...

when you do "show interface dialer0" and it shows the ip address, is it a public IP or private IP (10.x.x.x or 172.16-31.x.x or 192.168.x.x)?

Collapse -

The IP address

by LisaNels In reply to Your WAN IP?

From the 'show interfaces' command, I do see that the dialer has a IP address that is normal from my ISP. So I think the PPPoe is connecting. That's the only verification I know how to do. But I don't know how to see what DNS servers are returned etc. The ip showing was 174.27.32.144. This is a dynamic address.

Collapse -

Repost as 'Q&A'

by HAL 9000 Moderator In reply to Cisco 851W what should be ...

Try reposting this in the 'Q&A' forum. The 'Discussion' forum is for matters of general discussion, not specific problems in search of a solution. The 'Water Cooler' is for non-technical discussions. You can submit a question to 'Q&A' here:

http://www.techrepublic.com/forum/questions/post?tag=mantle_skin;content

There are TR members who specifically seek out problems in need of a solution. Although there is some overlap between the forums, you'll find more of those members in 'Q&A' than in 'Discussions' or 'Water Cooler'.

Be sure to use the voting buttons to provide your feedback. Voting a '+' does not necessarily mean that a given response contained the complete solution to your problem, but that it served to guide you toward it. This is intended to serve as an aid to those who may in the future have a problem similar to yours. If they have a ready source of reference available, perhaps won't need to repeat questions previously asked and answered. If a post did contain the solution to your problem, you can also close the question by marking the helpful post as "The Answer".

Collapse -

Running solution on the 851W

by LisaNels In reply to Cisco 851W what should be ...

Internal network on 192.168.5.0/24
PPPoE connection to Qwest.net
Wireless BSSID set to Lisa and no security
NAT working fine.


!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service sequence-numbers
!
hostname Cisco851w
!
boot-start-marker
boot-end-marker
!
logging buffered 10240
logging console critical
!
no aaa new-model
clock timezone PCTime -7
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
!
crypto pki trustpoint TP-self-signed-2247920426
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2247920426
revocation-check none
rsakeypair TP-self-signed-2247920426
!
!
crypto pki certificate chain TP-self-signed-2247920426
certificate self-signed 01
3080247 30201B0 A0030201 0202001 3000609 2A84886 F700101 04050030
31312F30 2D06355 0431326 494F532D 5365C66 2D536967 6E65642D 43657274
69666963 6174652D 32323437 39323034 3236301E 170D3032 30333031 30363138
34325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 32343739
32303432 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100EE4D 824FA222 7630002B F7B42AC8 E3578994 0669DEF0 9019756F 0901CB68
407629BB 293F961E 93349A30 57E8A391 88F66C11 46477CD8 D68EC802 CCD7C701
8CBD24AE 9896CF17 3D9E9FF5 C0F9E553 86985A15 B82B9C24 94934DCC 33BBDCF8
5F0C5278 760D9830 7ECD81D4 8CD583D1 E0B95D2C B4F0180C F10E5782 ECCDDC20
EA2F0203 010001A3 6F306D30 0F060355 1D130101 FF040530 030101FF 301A0603
551D1104 13301182 0F436973 636F3835 31772E6C 6F63616C 301F0603 551D2304
18301680 1443AAFC DCBC91FF 6F82F532 5F8B2F8F 54EDC2A4 FD301D06 03551D0E
04160414 43AAFCDC BC91FF6F 82F5325F 8B2F8F54 EDC2A4FD 300D0609 2A864886
F70D0101 04050003 818100DD CFA66E71 0DB1D1AE 034F8612 DC09EABD D48B2D0B
2A51288D 84A65EA9 1951B96B B7C7EB27 3A181C2E ECBD7116 F2739DB2 B98198CE
21BA13BB 963BDD30 09D49008 3181FDB9 BED5F68E DDC822F1 CE4D3DDF 82ADE956
576BDDFE 02CD72CB 2783FF4D 4E3F2839 6F4CFFFC 55CAC9BA 0820DE2F AAC24B8C
10F07C0A 864ABBA1 13CF93
quit
dot11 syslog
!
dot11 ssid Lisa
vlan 1
authentication open
guest-mode
!
no ip source-route
ip dhcp bootp ignore
!
!
ip cef
ip inspect name firewall tcp
ip inspect name firewall udp
ip inspect name firewall cuseeme
ip inspect name firewall h323
ip inspect name firewall rcmd
ip inspect name firewall realaudio
ip inspect name firewall streamworks
ip inspect name firewall vdolive
ip inspect name firewall sqlnet
ip inspect name firewall tftp
ip inspect name firewall ftp
ip inspect name firewall icmp
ip inspect name firewall sip
ip inspect name firewall esmtp max-data 52428800
ip inspect name firewall fragment maximum 256 timeout 1
ip inspect name firewall rtsp
ip inspect name firewall pptp
ip inspect name firewall skinny
no ip bootp server
no ip domain lookup
ip domain name local
!
!
!
file verify auto
username cisco privilege 15 secret 5 $KInL/yXW0.
username lisa privilege 15 secret 5 $1$x$cPniGAXT/
!
!
archive
log config
hidekeys
path flash:config
write-memory
!
!
ip tcp selective-ack
ip tcp timestamp
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description Outside Interface
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache cef
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers tkip
!
ssid Lisa
!
speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
station-role root
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
no ip address
ip tcp adjust-mss 1452
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Dialer0
ip address negotiated
ip access-group 101 in
no ip redirects
no ip unreachables
ip mtu 1492
ip inspect firewall out
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp chap hostname f17@qwest.net
ppp chap password 7 1415212EE0933
ppp ipcp dns request
ppp ipcp route default
!
interface BVI1
ip address 192.168.5.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.5.20 22 interface Dialer0 22
ip nat inside source static tcp 192.168.5.20 5060 interface Dialer0 5060
ip nat inside source static udp 192.168.5.20 5060 interface Dialer0 5060
!
access-list 1 remark The local LAN.
access-list 1 permit 192.168.5.0 0.0.0.255
access-list 2 remark Where management can be done from.
access-list 2 permit 192.168.5.0 0.0.0.255
access-list 23 remark CCP_ACL Category=17
access-list 23 permit 192.168.5.0 0.0.0.255
access-list 101 remark Traffic allowed to enter the router from the Internet
access-list 101 remark CCP_ACL Category=17
access-list 101 permit tcp any any eq 22
access-list 101 deny ip 0.0.0.0 0.255.255.255 any
access-list 101 deny ip 10.0.0.0 0.255.255.255 any
access-list 101 deny ip 127.0.0.0 0.255.255.255 any
access-list 101 deny ip 169.254.0.0 0.0.255.255 any
access-list 101 deny ip 172.16.0.0 0.15.255.255 any
access-list 101 deny ip 192.0.2.0 0.0.0.255 any
access-list 101 deny ip 192.168.0.0 0.0.255.255 any
access-list 101 deny ip 198.18.0.0 0.1.255.255 any
access-list 101 deny ip 224.0.0.0 0.15.255.255 any
access-list 101 deny ip any host 255.255.255.255
access-list 101 permit tcp any eq 22 any
access-list 101 remark From VoipVoip.com
access-list 101 permit ip host 69.90.209.57 any
access-list 101 deny icmp any any echo
access-list 101 deny ip any any log
access-list 102 remark Traffic allowed to enter the router from the Ethernet
access-list 102 remark CCP_ACL Category=17
access-list 102 permit ip any host 192.168.5.1
access-list 102 deny ip any host 192.168.5.255
access-list 102 deny udp any any eq tftp log
access-list 102 deny ip any 0.0.0.0 0.255.255.255 log
access-list 102 deny ip any 10.0.0.0 0.255.255.255 log
access-list 102 deny ip any 127.0.0.0 0.255.255.255 log
access-list 102 deny ip any 169.254.0.0 0.0.255.255 log
access-list 102 deny ip any 172.16.0.0 0.15.255.255 log
access-list 102 deny ip any 192.0.2.0 0.0.0.255 log
access-list 102 deny ip any 198.18.0.0 0.1.255.255 log
access-list 102 deny udp any any eq 135 log
access-list 102 deny tcp any any eq 135 log
access-list 102 deny udp any any eq netbios-ns log
access-list 102 deny udp any any eq netbios-dgm log
access-list 102 deny tcp any any eq 445 log
access-list 102 permit ip 192.168.5.0 0.0.0.255 any
access-list 102 permit ip any host 255.255.255.255
access-list 102 deny ip any any log
dialer-list 1 protocol ip permit
no cdp run
arp 192.168.5.199 001c.10e2.5e44 ARPA
arp 192.168.5.203 001c.10e2.5e24 ARPA
!
control-plane
!
bridge 1 route ip
banner motd

!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 2 in
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end

Collapse -

See my post to this question in Q & A

by NetMan1958 In reply to Cisco 851W what should be ...

I posted an answer to this in the Q & A section

Back to Windows Forum
5 total posts (Page 1 of 1)  

Operating Systems Forums