General discussion

Locked

Cisco 871w refuses to grab an IP address from Vlan.

By CrazyDonJuan ·
Hi Pros,
I been fighting with this for days now. I have configured a Cisco 871W,a laptop is able to associate with the SSID, but can't grab an Ip from the DATA vlan.All the research i done shows that the configuration is ok.
There is the config bellow:

!
service timestamps log datetime msec
service password-encryption
!
hostname VPN-spare-test
!
dot11 ssid VPN-SPARE-TEST
vlan 1
max-associations 5
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7 cisco12
!
dot11 ssid dot11 ssid VPN-SPARE-TEST
!
ip source-route
no ip dhcp use vrf connected
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.x.x 192.168.x.10
ip dhcp excluded-address 192.168.x.245 192.168.x.254
ip dhcp excluded-address 10.169.x.1 10.169.xx.10
ip dhcp excluded-address 10.169.xx.245 10.169.xx.254
!
ip dhcp pool DHCPPOOL-VOICE
network 10.169.xx.0 255.255.255.0
option 150 ip 10.xx.0.254
default-router 10.x.x.1
dns-server 10.xx.0.254
!
ip dhcp pool DATA_POOL
network 192.168.xx.0 255.255.255.0
dns-server 10.xx.xx.254
default-router 192.168.xx.1
netbios-name-server 10.xx.xx.254
!
!
ip cef
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
switchport priority default 3
spanning-tree portfast
!
interface FastEthernet3
switchport voice vlan 2
switchport priority extend cos 5
spanning-tree portfast
!
interface FastEthernet4
ip address dhcp
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 mode ciphers tkip
!
broadcast-key vlan 1 change 10
!
!
ssid VPN-SPARE-TEST
!
ssid dot11 ssid VPN-SPARE-TEST
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no cdp enable
!
interface Dot11Radio0.2
encapsulation dot1Q 2
!
interface Vlan1
description DATA-VLAN
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan2
description VOICE-VLAN
ip address 10.xxx.x.1 255.255.255.0
!
interface BVI1
description DATA_BRIGING
ip address 192.xx.x.1 255.255.255.0
!
bridge 1 protocol ieee
bridge 1 route ip
!
thanks.
Crazy

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

hum so your using 2 scopes on 1 DHCP server

by CG IT In reply to Cisco 871w refuses to gra ...

assigning one scope for one vlan and another scope for another vlan and the DHCP server is on which Vlan? the default? then intervlan routing from vlans so that clients can get their address from DHCP is done ? ....

Collapse -

Cisco 871 Refuses to grab Ip add from wireless vlan

by CrazyDonJuan In reply to hum so your using 2 scop ...

Yes, I do have 2 scopes, one is for voip(10.x.x.x) phone and the other one is for data(192.x.x.x).As I can only have 2 vlans in the 871, so vlan 1 default vlan is for data and vlan 2 is for voice.

Thanks,

Back to Networks Forum
2 total posts (Page 1 of 1)  

Hardware Forums