Discussions

Cisco Router Connection to Internet

Tags:
+
0 Votes
Locked

Cisco Router Connection to Internet

amanjsingh
External IP Address: 134.74.126.111
External Subnet: 255.255.255.0

External Gateway: 134.74.126.50

Internal IP Scheme
Internal Router Address: 192.168.30.97
Internal Subnet: 255.255.255.224
Internal Client to test: 192.168.30.100

I want to connect to internet through this CISCO router 2621.

Ping status -

From testing client 192.168.30.100 I can ping -
134.74.126.111
192.168.30.97 but NOT 134.74.126.50 (ie the external gateway)

From router console I can ping every address.

Please help.

AJ
  • +
    0 Votes
    Tig2

    First- great information, but not enough. Without seeing your router config, I can't tell if this is a lock in or poor routing script. Help us out on that.

    Also- please post this to the Questions forum. Copy your original information and select the "Ask a Question" button. That will get you in front of people who answer questions but don't necessarily come to the discussion forum.

    I really think that the answer is in your router config but can't even begin to point you without better information.

    +
    0 Votes
    amanjsingh

    Current configuration : 792 bytes

    version 12.2
    service timestamps debug uptime
    service timestamps log uptime


    hostname cisco4

    enable secret %%%%%%%%%%%%%%%%%%%%%%%%
    enable password ena
    ip subnet-zero

    interface fastEthernet0/0
    ip address 134.74.126.111 255.255.255.0
    ip nat outside
    speed auto
    full-duplex


    interface serial0/0
    no ip address
    shutdown

    interface fastEthernet0/1
    ip address 192.168.30.97 255.255.255.0
    ip nat inside
    speed auto
    full-duplex


    iterface ethernet1/0
    no ip address
    half-duplex


    ip classless
    ip http server

    dialer-list 1 protocol ip permit
    dialer-list 1 protocol ipx permit

    line con 0
    line aux 0
    line vty 0 4
    password ena
    login
    line vty 5 15
    password ena
    login

    no scheduler allocate
    end

    ------------------
    sh ip route --

    gateway of last resort is not set

    C 192.168.30.0/24 is directly connected. FastEthernet0/1
    134.74.0.0/24 is subnetted, 1 subnets
    C 134.74.126.0 is directly connected, FastEthernet0/0

    ---------------------
    I want to connect my internal LAN to internet through this router. My organization Gateway that I need to be able to connect to is 134.74.126.50 but I am unable to do that. I am able to ping 134.74.126.111 and 192.168.30.97 from my machine (192.168.30.100)


    Thanks a lot for your help.

    +
    0 Votes
    mvasquez

    create a some static routes and you'll be set.

    +
    0 Votes
    deepsand

    Try the "Questions" forum; the "Discussion" forum is for matters of general discussion, not specific problems in search of a solution.

    Post problems such as this to the "Question" forum, rather than the "Discussion" forum. There are those who specifically seek out problems in need of a solution, and that's where they go to look for such.

    Additionally there are the benefits that:

    1) The "Questions" forum provides for your feedback, by way of your being able to mark "helpful" responses as such. This does not necessarily mean that a given response contained the complete solution to your problem, but only that it served to guide you toward it. This is intended to serve as an aid to those who may in the future have a problem similar to yours, so that they might have a ready source of reference available, thereby perhaps obviating the need for them to repeat questions previously asked and answered.

    2) The revised TR makes it quite difficult to find both "Discussions" and "Questions" that have not had a fairly recent post, owing to some functions comingling them in the listings. By keeping each type in their respective forums, it is easier for all to find what they are looking for.

  • +
    0 Votes
    Tig2

    First- great information, but not enough. Without seeing your router config, I can't tell if this is a lock in or poor routing script. Help us out on that.

    Also- please post this to the Questions forum. Copy your original information and select the "Ask a Question" button. That will get you in front of people who answer questions but don't necessarily come to the discussion forum.

    I really think that the answer is in your router config but can't even begin to point you without better information.

    +
    0 Votes
    amanjsingh

    Current configuration : 792 bytes

    version 12.2
    service timestamps debug uptime
    service timestamps log uptime


    hostname cisco4

    enable secret %%%%%%%%%%%%%%%%%%%%%%%%
    enable password ena
    ip subnet-zero

    interface fastEthernet0/0
    ip address 134.74.126.111 255.255.255.0
    ip nat outside
    speed auto
    full-duplex


    interface serial0/0
    no ip address
    shutdown

    interface fastEthernet0/1
    ip address 192.168.30.97 255.255.255.0
    ip nat inside
    speed auto
    full-duplex


    iterface ethernet1/0
    no ip address
    half-duplex


    ip classless
    ip http server

    dialer-list 1 protocol ip permit
    dialer-list 1 protocol ipx permit

    line con 0
    line aux 0
    line vty 0 4
    password ena
    login
    line vty 5 15
    password ena
    login

    no scheduler allocate
    end

    ------------------
    sh ip route --

    gateway of last resort is not set

    C 192.168.30.0/24 is directly connected. FastEthernet0/1
    134.74.0.0/24 is subnetted, 1 subnets
    C 134.74.126.0 is directly connected, FastEthernet0/0

    ---------------------
    I want to connect my internal LAN to internet through this router. My organization Gateway that I need to be able to connect to is 134.74.126.50 but I am unable to do that. I am able to ping 134.74.126.111 and 192.168.30.97 from my machine (192.168.30.100)


    Thanks a lot for your help.

    +
    0 Votes
    mvasquez

    create a some static routes and you'll be set.

    +
    0 Votes
    deepsand

    Try the "Questions" forum; the "Discussion" forum is for matters of general discussion, not specific problems in search of a solution.

    Post problems such as this to the "Question" forum, rather than the "Discussion" forum. There are those who specifically seek out problems in need of a solution, and that's where they go to look for such.

    Additionally there are the benefits that:

    1) The "Questions" forum provides for your feedback, by way of your being able to mark "helpful" responses as such. This does not necessarily mean that a given response contained the complete solution to your problem, but only that it served to guide you toward it. This is intended to serve as an aid to those who may in the future have a problem similar to yours, so that they might have a ready source of reference available, thereby perhaps obviating the need for them to repeat questions previously asked and answered.

    2) The revised TR makes it quite difficult to find both "Discussions" and "Questions" that have not had a fairly recent post, owing to some functions comingling them in the listings. By keeping each type in their respective forums, it is easier for all to find what they are looking for.