General discussion

  • Creator
    Topic
  • #2190734

    Configure Cisco Router for Internet

    Locked

    by bob smithers ·

    I have a complex problem that someone can probably resolve quickly. I have a Cisco 1721 that I’m trying to configure to use an wireless antenna connection. I’ll list the config that I’ve been trying to get to work below using an ethernet WIC. Keep in mind that I have used bogus IP addresses for security reasons in this post. I will be more than happy to issue all of the advertised points if you can help. Thanks!

    External IP Address: 10.1.7.50
    External Subnet: 255.255.255.240
    External Gateway: 10.1.7.51
    External Primary DNS: 12.172.204.3
    External Secondary DNS: 64.146.3.126

    Internal IP Scheme
    Internal Router Address: 192.168.0.1
    Internal Subnet: 255.255.255.0
    Internal Client to test: 192.168.0.50

    Here is the config that I’ve been trying to use. The cisco router will be connecting to an ethernet device connected to the antenna. The external gateway address is this ethernet device.

    I really appreciate any help. If you need any further information, please let me know. I will post the config in a follow-up post. Thanks again.

All Comments

  • Author
    Replies
    • #3046769

      Reply To: Configure Cisco Router for Internet

      by bob smithers ·

      In reply to Configure Cisco Router for Internet

      !
      service timestamps debug uptime
      service timestamps log uptime
      service password-encryption
      no service tcp-small-servers
      no service udp-small-servers
      !
      hostname Cisco1721
      !
      enable password HELPME
      !
      no ip name-server
      !
      ip subnet-zero
      no ip domain-lookup
      ip routing
      !
      interface FastEthernet 0
      no shutdown
      description connected to EthernetLAN
      ip address 192.168.0.1 255.255.255.0
      ip nat inside
      keepalive 10
      !
      interface Ethernet 0
      no shutdown
      description connected to Internet
      ip address 10.1.7.50 255.255.255.240
      ip nat outside
      keepalive 10
      !
      ! Access Control List 1
      !
      no access-list 1
      access-list 1 permit 192.168.0.0 0.0.0.255
      !
      ! Dynamic NAT
      !
      ip nat translation timeout 86400
      ip nat translation tcp-timeout 86400
      ip nat translation udp-timeout 300
      ip nat translation dns-timeout 60
      ip nat translation finrst-timeout 60
      ip nat inside source list 1 interface Ethernet 0 overload
      !
      router rip
      version 2
      network 192.168.0.0
      passive-interface Ethernet 0
      no auto-summary
      !
      !
      ip classless
      !
      ! IP Static Routes
      ip route 0.0.0.0 0.0.0.0 Ethernet 0
      no ip http server
      no snmp-server location
      no snmp-server contact
      !
      line console 0
      exec-timeout 0 0
      password HELPME
      login
      !
      line vty 0 4
      password HELPME
      login
      !
      end

    • #3046766

      Reply To: Configure Cisco Router for Internet

      by bob smithers ·

      In reply to Configure Cisco Router for Internet

      Point value changed by question poster.

      These are all the points I have available. Please help!

    • #3047365

      Reply To: Configure Cisco Router for Internet

      by sgt_shultz ·

      In reply to Configure Cisco Router for Internet

      sorry i can’t help more but maybe you want run the router in bridge mode. what mode are you using, do you know?

    • #3047339

      Reply To: Configure Cisco Router for Internet

      by cg it ·

      In reply to Configure Cisco Router for Internet

      humm, a 1721 WAN is connected to an ethernet device. [Is the WAN port ethernet and your sure it’s ethernet and not DSL or T1 or BRI?]That device also has the antenna connected to it for wireless?

      The device is the gateway to the internet. If that device isn’t a router that performs NAT, it will never work. The E0 [the WAN port]on the 1721 is packaged by the 1721 and that is for the subnet that is the device and the 1721. If the device doesn’t repackage the packets for NAT and determine if the packets are not destined for the LAN therefore foward to the next router no traffic will get to the internet.

      • #3047337

        Reply To: Configure Cisco Router for Internet

        by cg it ·

        In reply to Reply To: Configure Cisco Router for Internet

        If you swapped it around and the antenna is on a device like an access point and that is connected to the LAN ports on the Cisco, then the Cisco will function fowarding packets not destined for the LAN to the next router.

        If you aren’t getting anything out of the 1721, disable the access list you have because there is an implied deny access in Cisco Access lists [default is to deny when there is no other rule specifically allowing, which you don’t see at the end of the access list]

      • #3047165

        Reply To: Configure Cisco Router for Internet

        by bob smithers ·

        In reply to Reply To: Configure Cisco Router for Internet

        Yes, it’s deffinetely two ethernet devices connecting together. The router is using and ethernet WIC and it’s connecting to an ethernet radio modem running in a router mode. Line Protocol shows that it’s up, and just can’t get anywhere. I’m so confused on this one.

    • #3055022

      Reply To: Configure Cisco Router for Internet

      by cg it ·

      In reply to Configure Cisco Router for Internet

      If the radio modem is running in router mode,and the radio modem antenna has to pickup the signal from the ISP, the modems antenna is the WAN port. If the ISP is providing an IP address to the radio modem/router there should be a WAN status on the radio/modem and a connection made. It will give the ISP assigned public IP address for you, subnet mask and DNS servers and default gateway.
      The LAN side of the radio modem/router needs a static IP address, subnet mask and DNS servers.

      The Cisco router WAN port is then configured with a static IP address, subnet mask with your ISP DNS server address[es] and the default gateway is the radio modem/router LAN IP address. If the radio modem/router is also a firewall, disable your access list [disable it anyway until you get connectivity].

      The Cisco router LAN is a different subnet. Assign the Cisco LAN ethernet interface with an IP address Subnet Mask and ISP DNS servers. Users using the 1721 need to have the default gateway the 1721 LAN IP address.

      • #3055017

        Reply To: Configure Cisco Router for Internet

        by cg it ·

        In reply to Reply To: Configure Cisco Router for Internet

        Note: the WAN 1721 connects to the LAN side of the Radio modem/router both are on the same subnet.

        The 1721 LAN and all other devices on the LAN side are on the same subnet [unless you subnet again].

        The ISP and the WAN port of the radio modem/router are on the same subnet.

        Since you run an access list on the 1721 WAN you should disable it because unless specifically allowed all traffic is blocked. So DNS over port 53 might be blocked if you didn’t have an allow rule in the access list. [you can enable the access list later]. Remember you need DNS traffic to get to the web because when you use a name in the browser, your asking for DNS resolution and if not resolvable on the LAN it’s fowarded out to internet name servers for resolution. If resolved, that info has to get back to the user to display the correct web page.

      • #3064912

        Reply To: Configure Cisco Router for Internet

        by bob smithers ·

        In reply to Reply To: Configure Cisco Router for Internet

        Excellent information. Still have not resolved the issue as of yet though.

    • #3064945

      Reply To: Configure Cisco Router for Internet

      by kryptos ·

      In reply to Configure Cisco Router for Internet

      Try below; probably it will help you locate the issue.

      1) Ping your Ethernet 0 interface.
      If successful (your LAN and router configuration and interfaces are fine)
      2) Ping the next hope (i.e. wireless device Ethernet interface (connected to routers ethernet0)).
      If successful (router to wireless dive communication is fine.)
      3) Ping wireless device?s wireless interface
      If successful, may not be the issue with your setup contact ISP or check the DNS.

      Try these from your router and test pc.

      • #3064913

        Reply To: Configure Cisco Router for Internet

        by bob smithers ·

        In reply to Reply To: Configure Cisco Router for Internet

        Thanks for the help. Here is what I can do at the moment.

        Can Ping Etherent 0 Interface
        Can Ping Next Hop (Wireless Ethernet Interface)
        Cannont ping wireless devices’s wireless interface or external DNS servers.

    • #3064585

      Reply To: Configure Cisco Router for Internet

      by kryptos ·

      In reply to Configure Cisco Router for Internet

      Check weather the wireless interface is UP.

      Self ping wireless interface from same wireless router.

      if pinging
      Check weather the route to 192.168.0.0/24 is properly set to gateway 10.1.7.50 (routers external Ethernet interface) on wireless router.

      Also check the route on Ethernet router; o/o is routed to 10.1.7.51

      This is enough to for get a ping responds from the interface (assuming ICMP is not blocked).

      If not pinging- interface may not be UP,
      Try if any kind of loop back is possible on the interface, if possible enable loop back and ping. If interface is ok it should respond.

      Try debug on wireless device ( i don’t know weather that possible with your device)(debug ip packet details -work on Cisco routers. be careful with the debug commands).

      Check the ARP table in wireless router. If wireless interface is up and running it should have ARP entry of next hope.

      Ask ISP to ping your wireless interface.

      good luck,

    • #3058251

      Reply To: Configure Cisco Router for Internet

      by midwest1 ·

      In reply to Configure Cisco Router for Internet

      Your router setting look ok but did not see any speed settings, All so did see any metion of what type of wire less AP. Cisco AP’s like the setting of 100 full duplex for then to work correctly you can ping them connect to them but they will not function correctly. Also did you check to see if the radio side of the AP is up.

    • #3117457

      Reply To: Configure Cisco Router for Internet

      by mediainc1978 ·

      In reply to Configure Cisco Router for Internet

      Hi,

      Your router configration is oky but u have to add default gateway for external network.

      Ask Radio Modem for gateway and configure the gateway.

      u can reach me at mediainc1978@yahoo.com

      other configration is oky.

      U r reching up to radiomodem but not to isp because gateway is not configured.

      Narendra
      systems

    • #3253837

      Reply To: Configure Cisco Router for Internet

      by kevin ·

      In reply to Configure Cisco Router for Internet

      Hi Bob,
      Did you solve your wireless router configuration?

      I just signup for nextweb wierless. I’m using cisco 2611 dual ethernet.

      Can you help sent me a working configuration sample.

      I need to configuare my network for both Internet access for internal LAN and server web hosting.

      I was assign a subnet and a block of IP.
      207.47.80.192 Subnet 255.255.255.224
      207.47.80.193 is the Antenna IP also my gateway.
      Useable IP range 194-222.
      I’m plan on using 194-200 for server hosting. 221 and above for Local LAN assign to workstation.
      My acc list should allow stand IP traffic like web, FTP, DNS, Email to reach my internet server only IP 194-200. Thank for helping.

    • #3284164

      Reply To: Configure Cisco Router for Internet

      by jim ·

      In reply to Configure Cisco Router for Internet

      I have a similar problem. I am using my 1721 as a gateway to the internet via DSL. The LAN side is connected to a switch where local PCs get to the internet just fine. The switch is connected to a wireless bridge to a different building. PCs at the remote building can ping the 1721 and use resources on the LAN but they cannot get to the INternet. When I use a simple Linksys consumer level gateway the remote site gets out just fine, but with the faster 1721, the remote site cannot get out to the internet.

      I suspect it has something to do with the NAT. Perhaps the 1721 is trying to assign NAT IP numbers to the MAC address and the MAC address for the packets appear to be from the closest wireless bridge device. Does this make any sense?

      -jim

    • #2879963

      Cisco 1721 ATT DSL connection HELP

      by beast99 ·

      In reply to Configure Cisco Router for Internet

      Hello,
      I am new with Cisco and trying to get my Cisco 1721 with a ADSL WIC to work with ATT DSL. All my interfaces shows up, but I still cannot connect to the Internet. this is for home use only. Any assistance is greatly appreciated. Below is my config .

      Cisco_1721>
      Cisco_1721>
      Cisco_1721>
      Cisco_1721>
      Cisco_1721>en
      Cisco_1721#sho run
      Building configuration…

      Current configuration : 1547 bytes
      !
      ! No configuration change since last restart
      !
      version 12.3
      service timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption
      !
      hostname Cisco_1721
      !
      boot-start-marker
      boot-end-marker
      !
      logging buffered 4096 debugging
      !
      mmi polling-interval 60
      no mmi auto-configure
      no mmi pvc
      mmi snmp-timeout 180
      no aaa new-model
      ip subnet-zero
      !
      !
      ip dhcp excluded-address 192.168.1.1
      !
      ip dhcp pool HUYHO.NET
      network 192.168.1.0 255.255.255.0
      default-router 192.168.1.254
      domain-name HUYHO.NET
      dns-server 68.94.156.1 68.94.157.1
      !
      ip cef
      !
      !
      bridge irb
      !
      !
      interface ATM0
      no ip address
      no atm ilmi-keepalive
      dsl operating-mode auto
      bridge-group 1
      pvc 0/35
      encapsulation aal5snap
      !
      !
      interface FastEthernet0
      ip address 192.168.1.254 255.255.255.0
      ip nat inside
      speed auto
      !
      interface Serial0
      no ip address
      shutdown
      no fair-queue
      !
      interface Dialer1
      ip address negotiated
      ip nat outside
      encapsulation ppp
      dialer pool 1
      dialer-group 1
      ppp authentication chap pap callin
      ppp chap hostname xxxxxx
      ppp chap password 0 xxxx
      ppp pap sent-username xxxx password 0 xxxxx
      ppp ipcp dns request accept
      !
      interface BVI1
      mac-address 000d.ed1b.6478
      ip address dhcp client-id FastEthernet0
      ip nat outside
      !
      ip nat inside source list 1 interface Dialer1 overload
      ip classless
      ip route 0.0.0.0 0.0.0.0 Dialer1
      no ip http server
      !
      !
      access-list 1 permit 192.168.1.0 0.0.0.255
      !
      bridge 1 protocol ieee
      bridge 1 route ip
      !
      line con 0
      line aux 0
      line vty 0 4
      login
      !
      end

      ==============
      Cisco_1721#sho ip int brief
      Interface IP-Address OK? Method Status Prot
      ocol
      ATM0 unassigned YES NVRAM up up

      BVI1 unassigned YES DHCP up up

      Dialer1 unassigned YES NVRAM up up

      FastEthernet0 192.168.1.254 YES NVRAM up up

      Serial0 unassigned YES NVRAM administratively down dow

Viewing 11 reply threads