Discussions

DHCP across multiple VLANS

+
0 Votes
Locked

DHCP across multiple VLANS

vyoungv
I have an HP L3 2626 with a single DHCP server configured with multiple scopes. I can't seem to get DHCP to pass out addresses to the correct VLAN network.

192.168.0.233 is the MS DHCP server
192.168.0.x is Vlan 1
192.168.8.x is Vlan 8

When I connect a PC to port 13 (untagged port) and pull a DHCP address it gets a .0 address and not an .8 address.

I have configured: ip helper, udp broadcast and dhcp relay. What am I doing wrong, any ideas? Do you think it could be the MS DHCP server?


ip default-gateway 192.168.0.2
sntp server 192.168.0.233
ip routing
ip udp-bcast-forward
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
vlan 1
name "Default PC 0"
untagged 1-12,14-26
ip address 192.168.0.8 255.255.255.0
tagged 13
exit
vlan 8
name "test"
untagged 13
ip address 192.168.8.8 255.255.255.0
ip helper-address 192.168.0.233
tagged 1-12,14-26
exit
dhcp-relay
ip route 0.0.0.0 0.0.0.0 192.168.0.2
  • +
    0 Votes
    Fregeus

    I know that you are dealing with multiple Vlans on a DHCP, the requester needs to be able to tell the DHCP on what network it wants an address. If not, the request will be on the default segment only.

    In this case, i do not see a default gateway for your segment 192.168.8.0. That information, in an HP appliance, could be supplied by the default gateway. Did you configure a DG for the .8.X network? If not, do so and try again.


    TCB

    +
    0 Votes

    DG

    vyoungv

    It looks like it only supports 1 DG on the switch. Do you know how to config the requester?

    +
    0 Votes
    Fregeus

    I haven't worked with HP switches in over 8 or 9 years. I just don't remember.

    But I don't think the DHCP is at fault here, i think it just doesn't get a notice from the request on which segment the address needs to be. Unfortunately, being a Cisco guy, I can't help you further than that.

    GL

    TCB

    +
    0 Votes
    ManiacMan

    It's called IP Helper in the Cisco world and allows for the retransmission of DHCP broadcasts across routed subnets. Recall that DHCP requests are broadcasts and that routers do not forward broadcasts, so you'll need some relaying mechanism to account for this. Check your documentation to determine what needs to be done to enable DHCP or BOOTP relaying.

    +
    0 Votes
    vyoungv

    I enabled a Helper address but it doesn't seem to help. I also enabled udp broadcast and that doesnt help either, but I am not sure if that is the same as bootp broadcast.

    +
    0 Votes
    CG IT

    In Cisco's world, for traffic between VLANs, gotta have a layer 3 device [a router]. Router on a stick is the easiest way to get traffic between VLANs. I assume you have VTP running on the switch.

    Trunk the port on the switch that will be used to connect to the router. the router and VLANs will use the trunk line.

    Use the encapsulation command with the VLAN # on the router subinterface config.

    You could create an access link and trunk links but for multiple VLANs, router on a stick is the easiest to setup.

    +
    0 Votes
    vyoungv

    The routing is working as I can manually assign an address on that VLAN segment and traffic goes through. DHCP does send an address it is just not from the correct scope. I wonder if it is my switch or the DHCP server?

    +
    0 Votes
    CG IT

    so now it's VLAN X isn't getting the correct IP address from the assigned scope from DHCP?

    then that's not a communications problem between VLANs that's DHCP.

  • +
    0 Votes
    Fregeus

    I know that you are dealing with multiple Vlans on a DHCP, the requester needs to be able to tell the DHCP on what network it wants an address. If not, the request will be on the default segment only.

    In this case, i do not see a default gateway for your segment 192.168.8.0. That information, in an HP appliance, could be supplied by the default gateway. Did you configure a DG for the .8.X network? If not, do so and try again.


    TCB

    +
    0 Votes

    DG

    vyoungv

    It looks like it only supports 1 DG on the switch. Do you know how to config the requester?

    +
    0 Votes
    Fregeus

    I haven't worked with HP switches in over 8 or 9 years. I just don't remember.

    But I don't think the DHCP is at fault here, i think it just doesn't get a notice from the request on which segment the address needs to be. Unfortunately, being a Cisco guy, I can't help you further than that.

    GL

    TCB

    +
    0 Votes
    ManiacMan

    It's called IP Helper in the Cisco world and allows for the retransmission of DHCP broadcasts across routed subnets. Recall that DHCP requests are broadcasts and that routers do not forward broadcasts, so you'll need some relaying mechanism to account for this. Check your documentation to determine what needs to be done to enable DHCP or BOOTP relaying.

    +
    0 Votes
    vyoungv

    I enabled a Helper address but it doesn't seem to help. I also enabled udp broadcast and that doesnt help either, but I am not sure if that is the same as bootp broadcast.

    +
    0 Votes
    CG IT

    In Cisco's world, for traffic between VLANs, gotta have a layer 3 device [a router]. Router on a stick is the easiest way to get traffic between VLANs. I assume you have VTP running on the switch.

    Trunk the port on the switch that will be used to connect to the router. the router and VLANs will use the trunk line.

    Use the encapsulation command with the VLAN # on the router subinterface config.

    You could create an access link and trunk links but for multiple VLANs, router on a stick is the easiest to setup.

    +
    0 Votes
    vyoungv

    The routing is working as I can manually assign an address on that VLAN segment and traffic goes through. DHCP does send an address it is just not from the correct scope. I wonder if it is my switch or the DHCP server?

    +
    0 Votes
    CG IT

    so now it's VLAN X isn't getting the correct IP address from the assigned scope from DHCP?

    then that's not a communications problem between VLANs that's DHCP.