Question

Locked

Double click selection behaviour

By skrappost66 ·
I have two computers (both Win XP SP3) with different behaviour in notepad and text fields in some other applications. When I double click a word with a hyphen (such as "abc-def") in notepad, on one computer the whole word gets selected. On the other only the part of the word where I clicked gets selected. This is the behaviour I want: the hyphen should act as a delimiter. How can I change this behaviour? In MS Office Word, the hyphen acts as a delimiter on both computers, so this seems like a system setting..?

Thanks!
/H?kan

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Notepad & Hyphens

by Darryl~ Moderator In reply to Double click selection be ...

When I read about your problem I thought it was a very interesting one.

I tried it out on a number of different computers I have & sure enough, it does it on some but not others....all versions of Word I tried just selected which ever "side" of the hyphen that was double clicked.

I did a little research on it & discovered some versions of Notepad use an "ini" file which is located in the C:\wondows\system32 folder (notepad.ini)...newer versions don't seem to use it & it's not there....I don't have a Vista or Windows 7 computer here at the moment, so I couldn't check them.

So I got looking at some other text editors (that's all most people ever use Notepad for anyway)and they all seem to respond the way you perfer.

Notepad2 is very popular...below is a link to download it if you care to give it a try....it has a lot more settings & features than Notepad but is still "lightweight" like Notepad.

http://tinyurl.com/6dsov

Collapse -

There's no 'notepad.ini' with Windows 7. { nt }

by OldER Mycroft In reply to Notepad & Hyphens
Collapse -

It seems to be the older ones

by Darryl~ Moderator In reply to There's no 'notepad.ini' ...

that have it....seems like XP SP2 installs (from a SP2 CD) don't have it but XP "original" installs do, even though they have SP3 installed....I can't figure it out, it's very odd.....it might have something to do with where the OS came from, like maybe a Microsoft OEM might have it but the IBM installs don't. It doesn't make any sense to me.

Now this is going to be one of those "stupid little things" that will bother me until I figure it out. X-(

Collapse -

windows 7

by PurpleSkys In reply to Notepad & Hyphens

i did a quick search and i couldn't find notepad.ini in win7

Collapse -

Solution: Double click selection behavior

by roristeel In reply to Double click selection be ...

Hi,

I recently ran into exactly the same problem, and after more hours than I'd like to admit, I found the culprit.

Control Panel / Regional and Language Options / Languages Tab / Supplemental language support

Install files for East Asian languages box will be ticked on the machine that DOESN'T select the hyphen.

(We do localisation so we had random machines with this requirement ticked which helped isolate the issue)

Good news is that removing the East Asian languages fixes the issue regardless of other factors.
Only issue is if you require those languages.

Hope that helps.

Rori Steel
Krome Studios

Collapse -

Hey kudos

by darpoke In reply to Solution: Double click se ...

on providing the answer - it was looking like one of those mysteries for the ages. I don't even use Windows and even *I* was needing closure! Thanks.

I'm a little disappointed that it's not a little '.ini' file that is the culprit. I've been getting some practice using Unix shells and they are preconfigurable with a variety of hidden (filename preceded with a '.') files such as .bash_profile or .bash_history. It's quite exciting to think that Windows software might support the same sort of thing.

I know it's a MS GUIfest but for a text editor it sounded feasible...

Back to Software Forum
7 total posts (Page 1 of 1)  

Software Forums