General discussion

Locked

Dual Boot

By royafm ·
I have 2 separate hard drive.

Drive1: 20 GB and has Win98 installed and running

Drive2: 40 GB and has NT2000 Advanced Server Installed.

I used to get the OS selection option everytime I started the PC. Now I dont. It goes straight to Win98. I played with Boot.ini many times, no use. It looks like the PC does not read the Boot.ini and goes to Win98 right away. I used Partition Magic and the 40 GB look slike intact and is there.

I am now stucked. I do thank you for any suggestion or help.

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Dual Boot

by Mikel~T In reply to Dual Boot

Have you tried to run the Advanced Server Installation and choosen to Repair. It sounds like the boot.ini isn't going to do squat since the W98 boot option has taken over. Once you've run the repair option, it should give you back your OS choice.
Hope this helps.

Mike

Collapse -

Dual Boot

by royafm In reply to Dual Boot

The question was auto-closed by TechRepublic

Collapse -

Dual Boot

by erikbutler In reply to Dual Boot

i set my pc up a bit differently. It is a little more hassle. i went into bios and selected to boot from disk0. then installed w2k server. then went into bios and select disk1 and loaded 98 onto it. then whick ever os you want just selct that diskin the bios. It provides better fault tollerance due to the fact that each os haas its own boot sector if the 98 crashes you can still boot into w2k and retrieve the files. Then i would recommend you createing an ERD for W2K this will hopefully aloow you to get this OS back in case of a crash

Collapse -

Dual Boot

by royafm In reply to Dual Boot

The question was auto-closed by TechRepublic

Collapse -

Dual Boot

by royafm In reply to Dual Boot

Thanks Mike and Erik for your suggestions. It gave me back my OS choice. I would like to share the solution with all but now, I have lost access to Win98.

In BIOS, I switched to boot from NT2K CD, then used the "Repair with Consule" option (since I did not have the ERD) and used the "FixBoot" command. It asked me if I want to FixBoot on default (C:) which I selected. Itr gave me the whole NT2K adv. Server OS with no loss to any apps or data. However, now I have lost access to Win98. At boot time, it now gives me the option of Win98 or NT2K, but choosing Win98, says "Invalid Disk". However, Boot.ini is now looked at. I played with it and I know that it is read by the system MBR at the boot time. I guess I need to modify Boot.ini and put the right line for Win98. But I am not sure what Multi(x)rdisk(y),.... I should use. Any idea.

Collapse -

Dual Boot

by maxwell edison In reply to Dual Boot

The simplest way to do this is to enter the BIOS and change the first boot device. you could easily change between booting on C-Drive or D-Drive.

MAxwell

Collapse -

Dual Boot

by royafm In reply to Dual Boot

The question was auto-closed by TechRepublic

Collapse -

Dual Boot

by royafm In reply to Dual Boot

This question was auto closed due to inactivity

Back to Windows Forum
8 total posts (Page 1 of 1)  

Operating Systems Forums