Question

Locked

Files Ready to Be Written to the Disc

By Healer ·
Every time I put a CD into the CD drive the Windows Explorer came up. Apart from displaying Files Currently on the Disc it always brought along an area saying Files Ready to Be Written to the Disc (1) for desktop.ini.

It always happens not only on Windows 7. I saw it happen on XP too. What could be the problem and how I can stop it from happening.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

I think...

by mamies In reply to Files Ready to Be Written ...

I think it happens if you try and drag and drop a file onto the CD. Are you able to delete the file and then what does it say.

After you delete it if you go back to the disk is it still their.

Thanks,

Collapse -

Here's how it happens and how to get rid of it

by Who Am I Really In reply to Files Ready to Be Written ...

beginning with XP MS included a CD Session burner;
which is depending on the setup & install either enabled by default or disabled by default
when you get that balloon in the system tray / notification area it means someone has either on purpose or by accident dragged & dropped files over the CD/DVD RW drive icon in the folder pane or my computer, which is really easy to do when trying to copy to a USB flash or external HDD that has the very next letter after the CD/DVD RW drive;

the method of preventing this is to be very careful when dropping in the folder pane, or if you prefer not to use the built in burning of XP & up:

(the following instructions are for XP, I will look up Vista / 7 and post if they are different)
a> open windows exploder and click my computer;
b> right click on the CD/DVD RW drive and choose properties;
c> select the recording tab in the properties dialog;
d> remove the mark from the "Enable CD recording on this drive" check box;

this only disables windows burning and doesn't disable third party burning like Nero, Roxio, etc.

to get rid of the balloon do this before disabling the CD burning:
a> open windows exploder;
b> with the CD/DVD RW drive empty or a blank CD in the drive; click on the drive in the folder pane or the balloon when it pops up;
c> the cached contents waiting to be burned should appear in the file window;
d> select the contents & delete (no this won't delete the original files only the cached info);
e> follow the "are you sure" prompts for deleting;
f> once the cache is empty, proceed with the previous instructions for turning off CD burning on the drive if you want it off.
__

In Vista / 7 it's in group policy:
Run "GPedit.msc"
and for those versions that don't contain group policy editor it had to be done manually in the registry

this page has the instructions:
howtogeek.com/howto/windows-vista/disable-windows-vistas-built-in-cddvd-burning-features/

Collapse -

Two ways to STOP this "problem".....

by js_pc_repair In reply to Files Ready to Be Written ...

The "desktop.ini" file that is being seen is by default, a Hidden system file.
You are seeing it because you have the function "Show hidden files" checked in the Folder Properties.

Go to:
Tools > Folder options > View > Hidden files and folders
Tick the button that says
"Don't show hidden files, folders and drives".

That will take care of it.
As soon as you hide the files, it will disappear.
BUT...
If you want to leave the setting to show hidden files, the only other way to turn this off is to disable the Windows Built-In Burning Features.

NOTE: This will ONLY disable the "Windows" CD/DVD Burning Feature and will NOT interfere with OTHER burning programs.

Using the Local Group Policy Editor:
1. Open the Start menu, and type "gpedit.msc" (without quotes) in the Search Line and press Enter.
NOTE: The gpedit.msc program is located in C:\Windows\System32\
2. If prompted by UAC, click on Yes.
3. In the left pane, click User Configuration
4. In the right pane, double click Administrative Templates then Windows Components then Windows Explorer.
5. Scroll down to "Remove CD Burning features"
6. Right click and choose "Edit".
Now this may seem a little backwards but...
7. To Disable CD and DVD Burning Features, select Enabled, click OK, and close the Group Policy Editor.

To Re-Enable the features, select either Not Configured or Disabled.

I hope this helps everyone with this issue.

Back to Hardware Forum
4 total posts (Page 1 of 1)  

Hardware Forums