General discussion

Locked

Files types change button grayed out

By JoseMeza ·
After opening windows explorer and selecting the folder options from the tool bar, I click on File types and notice that the CHANGE button is grayed out. Does anyone know how to enable this button?

Thank you.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by klpz In reply to Files types change button ...

It depends on what operating system you are using. You may be using an account that lacks proper admin privelages or if you are suing windows 2000 there may be a policy set that is preventing you fron changing this. You can try right clicking on a file of the type you would like to change and clicking open with and then telling it to always open the file with your preferred application.

Collapse -

by JoseMeza In reply to Files types change button ...

I'm using Windows 2000 server with the latest service packs and patches. I'm logged in as administrator (full rights).

Collapse -

by sgt_shultz In reply to Files types change button ...

here is an excerpt from microsoft knowledgebase article 257592
---------------------
On computers running Windows 2000 Terminal Services in Application Server mode, the UI may be locked down so that no one can change file type associations (not even administrators). This is done so that you can only edit the entries programmatically or by using MSI-based applications. This ensures that an inadvertent change in the UI does not effect the global file type associations across the computer running Terminal Services and all of its users. When this policy is enabled, the New, Delete, Change, and Advanced buttons are unavailable on the File Types tab of the Folder Options tool in Control Panel.

You can enable this functionality by changing the following registry entry:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer] "NoFileAssociate"=dword:00000000
---------------------

Collapse -

by timwalsh In reply to Files types change button ...

The Change button will remain inactive (greyed out) until you choose a file type with a valid extension. You cannot change the file association for a file with the extension type of (None).

Collapse -

by timwalsh In reply to

For some file types with a (None) extension, you can cahnge the associated program by clicking the Advanced button and choosing Edit.

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums