Gaming performance drastically lowered after install of Win7?

By wompai ·
Ey guys,

Yeah, as weird as the titel sounds, it's true... The PC I'm talking about recently had problems booting. It had some trouble with the RAM, but I've tried to fix that and it works perfectly. Now that I've got Windows xp replaced by windows 7, it's gaming performance drastically lowered for some reason. But I did my research, and this pc must be able to run Win7 and the game perfectly. It runs on a Pentium 4 2.6 GHz HT with 3GB of RAM. Also, it uses a Sapphire HD 4650 AGP with 1024MB VRAM. The game I'm talking about here is World of Warcraft. The user of the computer told me that it's performance seemed to have lowered since the crash. I could imagine that it has something to do with the driver, because I had some trouble finding the right driver, but I think I've got that covered...

Thanks in advance!

This conversation is currently closed to new comments.

13 total posts (Page 2 of 2)   Prev   01 | 02
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Reponse To Answer

by wompai In reply to Despite my extreme disple ...

You were just trying to help and as far as I can remember, this is the most useful and user-friendly tech forum I've ever used. So, actually I should be thanking you!

Collapse -

Thanks everybody!

by wompai In reply to Gaming performance drasti ...

Well, seems that a combination of settings where the problem. Setting the audio settings the hardware and choosing a separate specialized sound-card as my audio provider certainly helped. Also, some tweaking on RAM and CPU made some changes as well.


Back to Software Forum
13 total posts (Page 2 of 2)   Prev   01 | 02

Software Forums