How do I configure a Cisco ASA 5510 for Internet Access

By daniel.maisu ·
I am new to the Cisco ASA 5510 and want to configure it so everyone on it's inside interface has internet access.

Please give me a basic configuration steps on what to do. A sample config would help very much...

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Response to DANM on CISCO ASA 5510 configuration

by jkofinas In reply to How do I configure a Cisc ...

Step1: Configure a privileged level password (enable password)

By default there is no password for accessing the ASA firewall, so the first step before doing anything else is to configure a privileged level password, which will be needed to allow subsequent access to the appliance. Configure this under Configuration Mode:

ASA5510(config)# enable password mysecretpassword

Step2: Configure the public outside interface

ASA5510(config)# interface Ethernet0/0

ASA5510(config-if)# nameif outside

ASA5510(config-if)# security-level 0

ASA5510(config-if)# ip address

ASA5510(config-if)# no shut

Step3: Configure the trusted internal interface

ASA5510(config)# interface Ethernet0/1

ASA5510(config-if)# nameif inside

ASA5510(config-if)# security-level 100

ASA5510(config-if)# ip address

ASA5510(config-if)# no shut

Step 4: Configure PAT on the outside interface

ASA5510(config)# global (outside) 1 interface

ASA5510(config)# nat (inside) 1

Step 5: Configure Default Route towards the ISP (assume default gateway is

ASA5510(config)# route outside 1

Step 6: Configure the firewall to assign internal IP and DNS address to hosts using DHCP

ASA5510(config)# dhcpd dns

ASA5510(config)# dhcpd address inside

ASA5510(config)# dhcpd enable inside

The above basic configuration is just the beginning for making the appliance operational. There are many more configuration features that you need to implement to increase the security of your network, such as Static and Dynamic NAT, Access Control Lists to control traffic flow, DMZ zones, VPN etc.

BTW I pulled this info from another site... I was just toooo lazy to type it all out myself:-)


Collapse -

ASA configs

by daniel.maisu In reply to Response to DANM on CISCO ...

Thanks for the info. I will try it out and see if I can access the internet through the ASA.

Back to Networks Forum
3 total posts (Page 1 of 1)  

Hardware Forums