Question

Locked

How do I set up my computer to share my internet connection with my laptop?

By Whusmaname ·
My main box has Windows 7 Enterprise on it, and I have two network cards in the machine, one of which connects me to the router that allows me access to the internet. The other card, set on a different (static) IP address, connects my box to a Linux Laptop. How do I connect the Linux laptop to the internet through my Windows computer?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

You could try a CAT5 crossover cable,,,,,,

Go to your computer store and ask for a CAT5 Crossover cable and use that instead.
On your main computer select "Internet Connection Sharing" (ICS), you should be able to hook onto the internet that way.

Collapse -

Once you have the computers connected by Network Cables

by OH Smeg In reply to How do I set up my comput ...

And ideally a Crossover between the Desktop and NB, you can run the Network Setup Wizard in 7.

Set the 7 System to Connect Directly the the Internet and others computers on the Network connect through it then follow the prompts.

OH BTW you'll need Samba on the Note Book.

Col

Collapse -

Problems still occurring

by Whusmaname In reply to How do I set up my comput ...

My network card automatically swaps to crossover mode when it sees that it's connecting to another network card, so that's not a problem. What I can't seem to do is get the internet connection from the router, through my box (Windows 7) to my laptop (Linux - Lucid Puppy 5.1.1)

I have two connections: Local Area Connection and Local Area Connection 2.

Local Area Connection:
Network icon = "Home network"
Access type = "Internet", and
Homegroup = "Joined"

Local Area Connection 2:
Network icon = "Unidentified network - Public network"
Access type = "No network access", and
it won't allow me to change it, no matter WHAT I try.

Collapse -

Reponse To Answer

by OH Smeg In reply to Problems still occurring

Run the Network Setup Wizard

Collapse -

Reponse To Answer

by LeonBA In reply to Problems still occurring

Not sure if this will help, but you might try getting properties on the Local 2, then double-clicking on TCP/IP. Then click Advanced, and go to the Options tab and enable TCP/IP filtering (by clicking the Properties button).

Another possibility is you might have to disable the Windows firewall, or make an exception of some sort.

Back to Linux Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums