General discussion

Locked

how to get W98 to assign lpt2 to lpt2

By techrep ·
LPT1 is mapped to a novell printer, so i changed the on-board parallel port to lpt2, but W98 insists on calling it LPT1:. If i can just convince Windows that 0278/5 is LPT2: and lpt1 is a "virtual port" so i can map it, then i could put my attachedprinter on lpt2 and everyone (including my frustrated client) would be happy. but no, windows seems to think "one port - it must be port #1"

This conversation is currently closed to new comments.

27 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

how to get W98 to assign lpt2 to lpt2

by dmiles In reply to how to get W98 to assign ...

Open the printers window,then right click the printer you want to assign lpt2,select properties,select the details tab,there you should be able to assign and map to the port that you specify.
In case that it does not work,upon start-up click the delete button and then locate the port in the CMOS panel and change the port settings.

Collapse -

how to get W98 to assign lpt2 to lpt2

by techrep In reply to how to get W98 to assign ...

see next answer.

Collapse -

how to get W98 to assign lpt2 to lpt2

by techrep In reply to how to get W98 to assign ...

That WOULD HAVE been a good answer but if you read the question again, you should be able to determine that i had already changed the on-board port to lpt2. You will also read that Windows CALLS that port LPT1: In other words, you dodn't answer the question I asked. thanks anyhow.

Collapse -

how to get W98 to assign lpt2 to lpt2

by techrep In reply to how to get W98 to assign ...

Poster rated this answer

Collapse -

how to get W98 to assign lpt2 to lpt2

by mphoffar In reply to how to get W98 to assign ...

You may have to manually add in a LPT port using the add hardware wizard and also set the resources to match what you're setting in the bios. After that, you will have to either setup a new printer or go into the properties and point the port to LPT2 instead of LPT1 (which is usually chose as a default)

Of coarse I think the easier way would be to change the virtual port to LPT2 and leave the local on LPT1. That port should be local on the system and not effect anyone one else.

Mark

Collapse -

how to get W98 to assign lpt2 to lpt2

by techrep In reply to how to get W98 to assign ...

Poster rated this answer

Collapse -

how to get W98 to assign lpt2 to lpt2

by shawn.carney In reply to how to get W98 to assign ...

Well, this may not be feasible for you, but why not just map the Novell printer to LPT2 instead? Then you don't need to frustrate yourself figuring out how to get around the Windows conundrum...

Collapse -

how to get W98 to assign lpt2 to lpt2

by techrep In reply to how to get W98 to assign ...

Poster rated this answer

Collapse -

how to get W98 to assign lpt2 to lpt2

by burcjo In reply to how to get W98 to assign ...

lpt2 to lpt2...

0x3BC
0x378
0x278
The possible addresses of LPT ports. When you boot the machine, Microsoft OS's assign the first port it finds as LPT1. No matter what address it has, the first port it finds becomes LPT1. In order for you to have an LPT2, you MUST have an LPT1. The way to San Jose is to purchase a cheap LPT card and install it into your machine as LPT2 and attach your local printer to that port. Then you can have your virtual lpt1 redirected as you please AND your lpt2 to print from locally.

John

Collapse -

how to get W98 to assign lpt2 to lpt2

by techrep In reply to how to get W98 to assign ...

Poster rated this answer

Back to Windows Forum
27 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums