General discussion

Locked

IP Conflict

By bob ·
On Win XP machines, whether I use a wireless router, or a wired hub, I receive an icon that appears in my tray informing me that there is an IP Conflict.
Connecting just two machines at a time, neither will connect to the internet when this takes place.
If I unplug one or the other from either the router, hub or LAN card, the other connects immediately.
I am connecting from an always on, analog, DSL modem, configured from the first machine.
Have had great difficulties establishing a network, even using the XP network wizard.
My question is: Dismissing the idea of the network, how can I resolve the IP Conflict issue so that these machines can at least share an internet connection.

This conversation is currently closed to new comments.

19 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by softcorp.us In reply to IP Conflict

Hello Bob...

Let's get this to work!

My answer presumes your network is configurated as follows:

- DSL modem connected to broadband router that has both wireless and wired networking ports.

- Two PCs connected by wired networking directly to the broadband router.

-----------

Broadband routers typically provide DHCP. This means the router will assign an IP to client PCs that request it and will ensure each is unique.

Question: What is the make and model of your broadband router?

Since you're getting an IP conflict, one or both of your PCs is not configured for DHCP. To do that:

Network Connections -> Adapter -> Right Click -> Properties -> This connection uses the following items -> Internet Protocol (TCP/IP) -> Properties button

In the above dialog, select "Obtain an IP address automatically" and "Obtain DNS server address automatically". Click OK all the way out.

After you do the above on both systems, the IP address conflict should be removed, both systems should be able to connect to the Internt simultaneously, and both systems should be able to share files and printers with each other.

To see what IP address is assigned, type the following command in a Command box:

ipconfig /all

Did this solve your problem?

Were any of the presumptions incorrect? If so, please fill in the blanks so I can answer correctly.

-----Steve Jackson

CEO/CSA
Software Corporation (Softcorp)
http://www.softcorp.us/probono
Advanced pro bono tools and utilities free for personal use

Collapse -

by softcorp.us In reply to

Hello Bob...

What you're trying to do should work well. I have a similar setup in my office and it works fine. But...

I reviewed your IPCONFIG output. I suspect that there was more output from IPCONFIG that is showing in the window (some of it scrolled off the top of the window).

From what I _can_ see in your IPCONFIG otuput though, you're doing something on your PC that I have no experience with yet: IPv6 over IPv4 (Internet Protocol V6 over v4). "Teredo" is a technology that allows a client PC to run software that uses IPV6 over the IPV4 Internet. Beyond that, I don't know anything about it yet.

If you don't need "Teredo", I would consider removing it from your system. But, I really cannot advise this as I don't know why it's on your PC or whether you need it for something. It's a more complicated question and answer than I can engage in without a lot more information.

So, I'll defer to someone else on TR who can offer assitance with "Teredo" and broadband NAT.

Teredo Overview
http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/teredo.mspx

-----Steve

Collapse -

by bob In reply to

Thanks All!!
Using a bit of information from each of you, I haved learned an extraordinary of amount about wireless networking in Windows XP.
I still haven't managed an actual network, as yet, but with all you and you contributions, I at least am now able to share the internet connection without IP conflict errors.
As I am sure the rest of you are, I am limited on the amount of time that I can devote to a single issue, hence the delay in this note of appreciation. I will work with it, as I can, and I feel confident that with my newly learned information I will have a network up and working soon,
THANKS AGAIN, ALL!!!!

Collapse -

by Sue T In reply to IP Conflict

Does your ISP assign static IP addresses? If so you may have to set up internet connection sharing. Another thought, check both computers TCP/IP settings and make sure they are both set to use DHCP if your ISP doesn't use static IPs and they allow you to connect more than one computer.

Collapse -

by bob In reply to

Thanks All!!
Using a bit of information from each of you, I haved learned an extraordinary of amount about wireless networking in Windows XP.
I still haven't managed an actual network, as yet, but with all you and you contributions, I at least am now able to share the internet connection without IP conflict errors.
As I am sure the rest of you are, I am limited on the amount of time that I can devote to a single issue, hence the delay in this note of appreciation. I will work with it, as I can, and I feel confident that with my newly learned information I will have a network up and working soon,
THANKS AGAIN, ALL!!!!

Collapse -

by bytesolutions In reply to IP Conflict

I think Steve gave many valuable points to get it sorted out, but here is a test that you can try. If you know the range of IP addresses that you router is giving out, set each machine with a stitic IP address in the range. So for example, the SpeedSteam ADSL Routers has an IP address of 192.168.254.254 (default) and a subnet mask of 255.255.255.0, then in the config for each machine I would set 1 to be 192.168.254.1 and the other 192.168.254.2, each having a subnet mask of 255.255.255.0.

You can also add in the gateway (which would be 192.168.254.254 in my example), and if you know you ISP's DNS server addresses you can add them in too - sometimes it can assist when some machines are not connecting to the Internet.

Once this works, then you can start trying using dynamic address (DHCP serices), but at least you would have figured out the problem.

Collapse -

by bob In reply to

Thanks All!!
Using a bit of information from each of you, I haved learned an extraordinary of amount about wireless networking in Windows XP.
I still haven't managed an actual network, as yet, but with all you and you contributions, I at least am now able to share the internet connection without IP conflict errors.
As I am sure the rest of you are, I am limited on the amount of time that I can devote to a single issue, hence the delay in this note of appreciation. I will work with it, as I can, and I feel confident that with my newly learned information I will have a network up and working soon,
THANKS AGAIN, ALL!!!!

Collapse -

by dragonbill In reply to IP Conflict

I would have to second Steve there. Sue is also correct.

ipconfig /all is a great command line tool for this type of troubleshooting. Given that you should be good to go!

Bill

Collapse -

by bob In reply to

Poster rated this answer.

Collapse -

by wlbowers In reply to IP Conflict

Two computers cannot have the same address.

Go to Start/Run Now type cmd and press enter. This will bring up a command window.

Type ipconfig /all and press enter. This will give you information about the computer you are on. Do this on the other computer.

If the ip address is the same on both machines you must change one.

Now not knowing your configuration of your system lets go over that real quick.

Your DSL modem should go to the router.

The router output should go to the hub.

The computers should be connected to the hub.

The router is probably able to be a DHCP server. This should be enabled. This allows the computers to obtain a unique tcpip address while starting up.

To resolve the issue you have to change one of the machines addresses.

You do this in the control panel under Network Connections. Right click on the local area connection and get properties.

Now in the window, scroll down to tcpip and double click on it.

You have two choices in this window. Automatic and Use the Following IP Address.

If you are connected as I described above and have DHCP enabled you should have Automatic checked.

If Use the Following IP Address is checked all you have to do is change the last number in the ip address line by one digit.

Lee

Back to Windows Forum
19 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums