General discussion

Locked

LPT PORT ISSUE

By obiwaugh ·
I am working with some software that only seems to use printers using LPT ports...but the printer is not local, I've set it up using a TCP/IP port.

Is there any way to trick the system into thinking that my TCP/IP port is really an LPT? I know this is a long-shot....

Thanks!

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by cmiller5400 In reply to LPT PORT ISSUE

Yep. On a server create a printer with a port to the tcp/ip address and share that printer then do a net use lpt1: \\servername\printersharename

to remove the mapping
net use lpt1: /delete

Collapse -

by ozi Eagle In reply to LPT PORT ISSUE

This may work.
Open your printer's properties. Click on the PORTS tab. Tick enable printer pooling, leave the tick in the existing port and also tick the LPTx port.
What should happen is that the first free checked port will print. As there is no printer on LPTx then the next checked port will be used, i.e. the shared printer.

Collapse -

Printing to USB from LPT1

by contactus1 In reply to

Thank you for the solution to the problem of printing to a USB printer from programs looking for LPT1. I hunted all over the place for the answer. I found 2 different utilities that were "supposed" to do this, but neither one worked.

Yours was the only solution, and it was right there in the OS.

Thanks again.

Collapse -

net use

by vaman_smart In reply to LPT PORT ISSUE

use net use lpt command to set the netwok printer to lpt

Back to Windows Forum
4 total posts (Page 1 of 1)  

Operating Systems Forums