General discussion

Locked

Mail exchanger trouble with BIND 9.2

By jaolson40 ·
I'm having trouble getting mail into my domain (domain2)....outgoing mail is sent properly, but mail can not be received. Whenever I send mail to my domain, the message is bounced with a "Can't find Mail Exchanger or IP address #5.5.4"

Here is a copy of the zone file:

$TTL 86400
@ IN SOA host1.domain1.com. webmistress.domain2.com. (
2003022805
28800
14400
3600000
86400 )
NS host1.domain1.com.

A 1.2.3.4
www A 1.2.3.4
ftp A 1.2.3.4
mail A 1.2.3.4
domain2.com. IN MX 10 host1.domain1.com.

I can ping host1.domain1.com, I can connect to www.domain2.com. Domain1 also exists on the server, but does not receive mail. To my eye, everything looks like it's configured properly (as basic as it is).

Anyone have any ideas?

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Mail exchanger trouble with BIND 9.2

by jaolson40 In reply to Mail exchanger trouble wi ...

Point value changed by question poster.

Collapse -

Mail exchanger trouble with BIND 9.2

by curlergirl In reply to Mail exchanger trouble wi ...

It looks to me like you have your MX record pointing to host1.domain.com. But from your description it sounds to me like your actual mail exchanger machine is in domain2.com. So, I'm a bit confused. Your MX record should be pointing to your mail exchanger machine, which I assume is mail.domain2.com, or something similar. Hope this helps!

Collapse -

Mail exchanger trouble with BIND 9.2

by jaolson40 In reply to Mail exchanger trouble wi ...

Good suggestion, but ultimately it was my sendmail.cf that was the problem...went corrupt. Thanks, tho.

Collapse -

Mail exchanger trouble with BIND 9.2

by jaolson40 In reply to Mail exchanger trouble wi ...

I should mention that both domain1 and domain2 are on the same box, and sendmail is configured to accept mail for both domain1 and domain2.

Collapse -

Mail exchanger trouble with BIND 9.2

by LordInfidel In reply to Mail exchanger trouble wi ...

Just rewriting your zone file so that it makes sense.

$TTL 3h
domain1.com. IN SOA host1.domain1.com. webmistress@domain2.com. (
2003022805
28800
14400
3600000
86400 )

IN NS host1.domain1.com.
IN MX 20 mail

@ IN A 1.2.3.4
www IN A 1.2.3.4
ftp IN A 1.2.3.4
mail IN A 1.2.3.4

--------
What I did.

TTL- changed it to 3h, this allows you to make changes that will propagate better.

Added the domain that the zone is authoritative for. domain1.com. instead of @

changed webmistress.domain2.com to webmistress@domain2.com Assuming that it is a valid e-mail address.

Corrected where your mx records should be pointing to. You can also make it absolute like
mail.domain1.com. , if you use just the host name, then the host name must be in the same zone record as a A record or a CNAME.

Changed the way your host records were structerd and added the root domain.

Collapse -

Mail exchanger trouble with BIND 9.2

by LordInfidel In reply to Mail exchanger trouble wi ...

Forgot one entry, host1
----------------------------------

$TTL 3h
domain1.com. IN SOA host1.domain1.com. webmistress@domain2.com. (
2003022805
28800
14400
3600000
86400 )

IN NS host1.domain1.com.
IN MX 20 mail

@ IN A 1.2.3.4
host1 IN A 1.2.3.4
www IN A 1.2.3.4
ftp IN A 1.2.3.4
mail IN A 1.2.3.4

Collapse -

Mail exchanger trouble with BIND 9.2

by jaolson40 In reply to Mail exchanger trouble wi ...

Good suggestion, but ultimately it was my sendmail.cf that was the problem...went corrupt. Thanks, tho.

Collapse -

Mail exchanger trouble with BIND 9.2

by jaolson40 In reply to Mail exchanger trouble wi ...

This question was closed by the author

Back to Software Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums