General discussion

Locked

more DHCP

By mark_lt ·
After having to sort out the ealier problems with DHCp, its now working, except for the allocation of the default gateway.

There is no global scope, just the local one.

I removed DHCP, bounced, re-installed DHCP, re service pack6a.
gave it ascope from 01 to 254 (class c)
router = IP of main router
domain = domain name
wins = wins server IP (same as dhcp)
node type 0x8
DHCP has the 003 router entry and it does contain the correct IP for the gateway, but all clients get their own DHCP IP address as the default gateway, the same as how it works in RAS clients.

I have made a script to correct this at loging time but why do they not get the correct gateway ?

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

more DHCP

by garetjax In reply to more DHCP :(

Mark -

Sounds like you need to check the "Use Remote Gateway as Default" (or something equivalent) on the RAS clients. You find this setting in the DUN properties. You have to look at the DUN TCP/IP properties to access the checkbox. It is located at the bottom of the window.

Hope this helps.

Collapse -

more DHCP

by mark_lt In reply to more DHCP :(

No, the problem is that non DUN clients get the default gateway, the same way that RAS clients do.

that is that the gateway gets set to the same IP as the assigned network IP
thanks

Collapse -

more DHCP

by Inspectorclave In reply to more DHCP :(

I would try redoing your DHCP scope to include IP address from, say, 10 - 254 instead of 1 - 254. Assign the router an IP address between 1 and 10. You didn't specify in your last email, but if you are using the 1 - 254 for you leases in DHCP without exclusions, there is a possibility that another computer is being assigned the same IP address as the router. Good luck.

Collapse -

more DHCP

by mark_lt In reply to more DHCP :(

No, all static IP hardware is in a safe exclusion

thanks

Collapse -

more DHCP

by Phinaddict In reply to more DHCP :(

To kind of expand on the above answer. Say your router (default gateway) is 172.16.16.1, your DHCP server is 172.16.16.2 and your servers are 172.16.16.2-10. The network you would be on is 172.16.16.0. Set your clients to be 172.16.16.11-254 under scope properties with a valid default subnet mask. Set your DHCP global options to be
003 Router 172.16.16.1
006 DNS Servers (IP of DNS Server(s))
044 Wins/NBNS Servers (IP of WINS Servers)
046 WINS?NBT Node Type 0x8

Under your DHCP Scope enter
003 Router 172.16.16.1

The final step is to ensure that you activate your scope.

I can get you more help with more specifics on your network. E-mail me at phinaddict@hotmail.com

Good Luck!

Collapse -

more DHCP

by mark_lt In reply to more DHCP :(

this is exactly how it is all set up :(, mailed you

thanks

Collapse -

more DHCP

by simpsin In reply to more DHCP :(

You have to define the router (030 option il the "default" and "global" definitions on the DHCP server on your NT and don't forget to take out the gateway settings on your client machine, they might override the DCHP settings.

Collapse -

more DHCP

by mark_lt In reply to more DHCP :(

003 router is set correctly, and dhcp will overide any static entries anyway, but this is a new problem, all clients had correct IP before it died
thanks

Collapse -

more DHCP

by termiNaTor In reply to more DHCP :(

Read about it on Q167049
The DHCP option 003 (router) option was configured with a value that is not on
the local subnet

Collapse -

more DHCP

by mark_lt In reply to more DHCP :(

nope, that article is about only NT workstations as they check if the gateway is valid before they apply it, I have this same problem on win9x, NT and MAC's
thanks

Back to Windows Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Operating Systems Forums