General discussion

Locked

MSProxy server blocks ISP mail

By panikosvr ·
Our office (16PCs with win98) is connected to
the internet via MS proxy server 2.Internet
connection works fine with all PCs.The winsock proxy client is installed on all PCs.
The server (WindowsNT 4) has a Lan card that connects to the company LAN and an external
ISDN adapter thats connects to the ISP (internet).(We DONT have exchange/ mail server, installed anywhere in our office).
We need to use the ISP mail.
The problem is that the PCs can not have access to the ISP mail through the proxy.
We are using outlook 97 on the PCs.
The ports we are using for SMTP and POP3 are 25 and 110.
It seems that the MS Proxy is blocking the email protocols SMTP and POP3.
We tried using packet filtering and add the SMTP and POP3 protocols with no result.
We always get "the POP3 mail server failed to respond ...."
We can ping the mail server from the proxy server, and we can also get the mails from the proxy server but not from the client PCs.

Please help
Thank you

Panikos

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

MSProxy server blocks ISP mail

by ajrlanit In reply to MSProxy server blocks ISP ...

Did you set permissions for SMTP and POP3 in the Winsock protocol settings?

Collapse -

MSProxy server blocks ISP mail

by panikosvr In reply to MSProxy server blocks ISP ...

Yes we did set the permissions in the winsock protocol

Collapse -

MSProxy server blocks ISP mail

by cons In reply to MSProxy server blocks ISP ...

The permissions are set for SMTP and POP3 but still the clients can't seem to reach the server. Could anyone tell us how to setup the email client for reaching the server or the ISP mailbox?

Collapse -

MSProxy server blocks ISP mail

by panikosvr In reply to MSProxy server blocks ISP ...

Poster rated this answer

Collapse -

MSProxy server blocks ISP mail

by dhills In reply to MSProxy server blocks ISP ...

Go to the services icon in control panel and make sure that the SMTP service is installed and running on the Proxy server.

Collapse -

MSProxy server blocks ISP mail

by panikosvr In reply to MSProxy server blocks ISP ...

Poster rated this answer

Collapse -

MSProxy server blocks ISP mail

by joshg In reply to MSProxy server blocks ISP ...

try adding the IDENTD entry to the Packet filtering table.

Collapse -

MSProxy server blocks ISP mail

by panikosvr In reply to MSProxy server blocks ISP ...

Poster rated this answer

Collapse -

MSProxy server blocks ISP mail

by bbrown In reply to MSProxy server blocks ISP ...

You are on an internal network using MS proxy for Internet connectivity via NAT. Is your e-mail client aware of the Winsock proxy or is it looking strictly to the server connection. I would verify the clients have thier default gateway set to the proxy server's internal IP address. The proxy should be passing SMTP and POP3 traffic if you have enable this. The client should then communicate to the Internet directly sending all external traffic to the IP address of the Proxy.

Bobby

Collapse -

MSProxy server blocks ISP mail

by panikosvr In reply to MSProxy server blocks ISP ...

You were right:) . The default gateway on the clients was not set correctly.
I also had to make changes to the winsock proxy client (WSP client).In the server name I had to use the IP address of the proxy instead of the name of the server.
Thank you very much.
Regards
Panikos

Back to Windows Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Operating Systems Forums