General discussion

Locked

Need Help, file sharing through the netw

By llifan ·
I have 3 winXP prfessional version + 1 winXP home version workstations working behind the D-Link 4port router switch,which connects to internet.The thing is I cannot make the files in the different workstations be shared,each one can see the shared folders,but cannot access them. I opened the firewall on each of the workstation,but no access either. Another scenario is I cannot ping each other workstation's IP, although if ping its self is OK, and when I checked the file's property,there is no tab named permission, I don't know why. I am stuck there.

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Need Help, file sharing through the netw

by quintar51 In reply to Need Help, file sharing t ...

check the IP addresses on each of the machines. by default, they should be getting it from the router, unless you disabled it.

on each machine, go to start, Run, CMD, then type ipconfig.

each machine needs to have a unique IP address and should be on the same subnet. For example, machine 1 - 192.168.0.100
machine 2 - 192.168.0.101
machine 3 - 192.168.0.102
and so on.

Also, you need to make sure that they're in the same workgroup (MSHOME by default) by you can change it to whatever you wish.

Regarding you not being able to see the Permissions tab, make sure that each machine is formatted with NTFS.

Make sure you have a user account on each machine as well.

good luck,

Collapse -

Need Help, file sharing through the netw

by llifan In reply to Need Help, file sharing t ...

I checked everything,which seemed the same as you referred. I still cannot share the files, only the thing is I login as the administrator.

Collapse -

Need Help, file sharing through the netw

by Mike Jones In reply to Need Help, file sharing t ...

To get the permission tabs, select from Explorer Tools, Folder Options, View and untick, Use Simple File Sharing.

Also, go to the TCP/IP properties for the network connection and then to the WINS settings and make sure enable NETBIOS over TCP/IP is enabled.

Lastly, I assume you are using the personal firewall within XP. This should not be a problem, but disable both while testing, you can enable them after you have file sharing working. This will tell you whether the problem is with thefirewalls or not.

However, until you are able to ping the other workstation, most of the above is a mute point.

Can you ping the default gateway?

Are both PCs in the same workgroup?

What are the IP's for the different workstations?

What exactly is the error message reported when the connection fails or is refused?

Have you gone through the network setup wizard for sharing files?

Collapse -

Need Help, file sharing through the netw

by Mike Jones In reply to Need Help, file sharing t ...

Also, have you tried to connecting to the router admin page to make sure that file sharing is not disabled.

Collapse -

Need Help, file sharing through the netw

by llifan In reply to Need Help, file sharing t ...

Thank you guy. You are right. The Zoomlab is blocking everything.

Collapse -

Need Help, file sharing through the netw

by AirHockeyNinja In reply to Need Help, file sharing t ...

If you want to test this the easiest way possible, do the following:
0. Reload the home box with Pro before you go any further (I have never been able to get Home to network with any reliability, it could well be what is preventing you from succeeding in this).
1. Create an account on each machine with the same username and password.
2. make sure your router is handing out DHCP
3. set all computers to use dynamic IPs
4. turn off 'simple file sharing' as mentioned above
5. logon to all thecomputers with the user name created in step 1.
6. Ping each computer from the others, if any fail, stop and figure out why.
7. Run the network setup wizard on all computers
8. Create a share on one computer.
9. Configure the administrators group to specifically have full control of the share level permission, as well as the account you created in step 1 (which should be a member of the administrators group)
10. Place a small file into the share you created in step 8.
11. On one of the other computers, right click My Computer > Map Network Drive.
12. Select the share created in step 8 and assign a drive letter.
13. Test the access.
14. Adjust fire from there.

If this doesn't work, please contact me. I will try to guide you thru the process of trouble shooting. Hope this helps.

Joe

Collapse -

Need Help, file sharing through the netw

by llifan In reply to Need Help, file sharing t ...

Thanks so much guy. You help me to find out the permission tab of file. I have solved the problems.

Collapse -

Need Help, file sharing through the netw

by FranJenT79 In reply to Need Help, file sharing t ...

I have the same problem too. You can't get into the other shared folder because it's asking for a password, and you tried the one you have for that computer and the other computers and it still doesn't work. Well, if in that case you have your setting set to where your computer or user name is private. YOu have to change that in the control plane or in the Administratives Tools under Local Security Police.

Collapse -

Need Help, file sharing through the netw

by llifan In reply to Need Help, file sharing t ...

Poster rated this answer

Collapse -

Need Help, file sharing through the netw

by llifan In reply to Need Help, file sharing t ...

This question was closed by the author

Back to Windows Forum
10 total posts (Page 1 of 1)  

Operating Systems Forums