General discussion

Locked

no internet access after virus cleanup

By Sunny one ·
XP Home, fully maintenanced. Picked up a JScript virus. Cleaned it using Authentium. Now scans clean, but lost internet access. Have done ipconfig /release & /renew. loaded values look good. Can loopback by address and name. Have re-powered cable modem and router. (Other 'clean' PC on same peer to peer works fine). Removed and re-installed all network services, swapped ethernet cables and ports. 'Repaired' the connection. Ethernet connection is on MB, so I tried disabling it and installing a 'known good' NIC. Did not help. Connection status shows connected, but still no internet. Disabled the firewall. Still no access with IE6 or Netscape 7.2. Re-installed service pack 2 - I had been at SP2 plus all maint to current before. After re-installing SP2 I repeated all of the above. Ran the repair console, didn't help. Anybody think of anything I missed before I give it up and rebuild? It is not my internet service or net work hardware. The PC I write this on is running on the same equipment.
Thanks!

This conversation is currently closed to new comments.

17 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Sunny one In reply to

It was a good suggestion, thank you. I downloaded it on my working machine, burned a CD and ran WinSockXPFix on my machine with no internet access. It ran okay, but didn't fix my problem.

Collapse -

by adamcort In reply to no internet access after ...

Are you able to resolve a URL.

Try running nslookup from a command prompt.

Can you resolve an external address (www.bbc.co.uk)?

If that works, can you ping that address.

If not, try a tracert and see where it is stopping.

Post the results on the here

Collapse -

by Sunny one In reply to

all time out

Collapse -

by Blackcurrant In reply to no internet access after ...

Hi

Try this one instead:

http://www.cexx.org/lspfix.htm

When you removed the malware you will have also removed an LSP (layered service provider) inserted by the malware. This has broken the Winsock chain, which will disable Internet access. The LSPfix program repairs the chain. I have used it with success.

Good luck

Collapse -

by Sunny one In reply to

bummer. I tried it, but it didn't help.

Collapse -

Thanks a ton

by mrcgolf In reply to

Thanks, this worked for me. My daughter downloaded a messy virus, requiring three programs to remove most of it. This program completed the correction. Very appreciated!

Collapse -

by entawanabi In reply to no internet access after ...

To see if there is actually Access go to the menu bar and click 'VEIW', then to toolbar and click, at that pulldown select WEB and then push enter on the adding machine face. Put the inserter in the white strip and enter the MSN address; all this does is confirm that you have the ability to get to the web, it does not solve the problem; if by some chance you do not have web access thru this route go to help and see if you can get to one of the Microsoft help websites; again this does not solve the problem but it will show that you can get through to somewhere via the web.

Collapse -

by Sunny one In reply to

I truly have no internet.

Collapse -

by Blackcurrant In reply to no internet access after ...

Have you also tried running:

sfc /scannow

to make sure all system files are OK? Also, try disabling all non-MS I.E. Add-ons from the Programs tab on the I.E. properties page.

Back to Desktop Forum
17 total posts (Page 1 of 2)   01 | 02   Next

Hardware Forums