id="info"

General discussion

Locked

No workgroup access

By jgolden ·
I have three computers connected to a Lyksys WRT54G router with cable broadband. Desktop PC (Windows XP Service pack 2) is connected to router with ethernet cable, other two are wireless (Windows XP). All can connect to internet. Desktop can see other computers in workgroup, but cannot connect to to them. Wireless machines can connect to each other, but cannot see desktop. The problem seemed to happen after upgrading to service pack 2.

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CG IT In reply to No workgroup access

default SP2 installs a firewall and turns it on. try turning off the firewall. If access is restored, then it's the firewall blocking access.

Collapse -

by jgolden In reply to

Poster rated this answer.

Collapse -

by jgolden In reply to No workgroup access

I already tried shuttig off windows firewall. Even tried shutting down the router firewall. Still cannot connect.

Collapse -

by HAL 9000 Moderator In reply to No workgroup access

This might help but I'm not sure if MS has as yet worked out all the bugs with SP2 as a lack of wireless connectivity was a major issue when SP2 was applied.

http://www.microsoft.com/australia/windowsserversystem/oa2006/devices.aspx

Col

Collapse -

by jgolden In reply to

Poster rated this answer.

Collapse -

by CG IT In reply to No workgroup access

ok need some more info here. When you say they can't connect do you get a message that says you do not have permission or sufficent rights to access?
Are all computers on the LAN members of the same workgroup [and not just the default "workgroup" Windows create during install?
Are user accounts being used on all computers? [this would be the permission problem question I asked]

Wired or Wireless, all are on the same subnet [or should be] and if the wireless computers are actually connecting and getting an IP address from the router's DHCP, they are connected. Therefore the problem probably is related to permissions or that the computers actually don't belong to the same workgroup. run from a command prompt ipconfig/all and make sure all computers are obtaining an IP address from the router's DHCP server [linksys default subnet is 192.168.1.100 throught 192.168.1.140 so the computers addressing should be 192.168.1.100/102/ 103. if you see a 169.168.X.X on any of the computers then those with the 169.168.X.X are not getting an IP address from the router. Check your physical connection and wireless connections. If using WEP WPA keys make sure that the right key is being used and the right encryption is being used e.g. 64 bit encryption on the router requires 64 bit encryption on the computers and if using key 3 on the router, key 3 must be specified on the computers [and is the same key].

Collapse -

by p.j.hutchison In reply to No workgroup access

Make sure all appropiate user accounts are created on all PCs to use shared P2P resources.

Collapse -

by p.j.hutchison In reply to No workgroup access

Make sure all appropiate user accounts are created on all PCs to use shared P2P resources.

Collapse -

by S_K_K In reply to No workgroup access

Do this.
find out one of your Laptop IP Address by going to command prompt in one of your laptop and typing IPCONFIG. Note down this address and come back to your desktop. Go to command prompt and type ping (ip address of the laptop that you found) If you get a reply, then you are indeed having proper network connectivity between your desktop and laptop. After this if you say, you are not able to connect between desktop and laptop then it is definitely to do with permissions as other posters have indicated.

Collapse -

by spiralingcrazies In reply to No workgroup access

This worked for me - it turned out I had McAfee and Windows firewall enabled - I disabled windows firewall and added all IPs in the safe zone on my McAfee firewall. For example: 192.168.1.1 to 192.168.1.254. You could also try to just disable all firewalls for now.

Next step - I kept only one computer plugged into the Linksys at a time via its wired network card, not wireless. I left wireless on.(physically unplugged other PCs from the router). Then did the network setup on each machine:

Programs-Accesories-Communication-Network Setup Wizard

Click next to all screens until you get to:

When it asks you "Do you want to use shared connection" pick "No, let me choose another way to connect to internet", pick "This computer connect to the internet through a residential gateway", give the computer a name, hit next and call the network something, say HOME. FInish and repeat the same for all machines (you can create a network CD/floppy with the settings). Make sure only 1 machine connected to the Linksys at a time. Keep the name HOME on all other setups.

This fixed it for me.

Back to Windows Forum
10 total posts (Page 1 of 1)  

Operating Systems Forums