General discussion

Locked

Num Lock Turns off during boot

By jeffrey.grant ·
I have 3 different systems that are Windows NT and when the OS starts up it turns the Num Lock off.
I have BIOS set to turn it on and it does and remains on until NT hits the inital logon screen, then it shuts off.
What I would like to know is there any way to fix this? I would like it to be on.
Is this a registry setting and if so where??

Thanks,

Jeffrey A. Grant
Information Systems

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Num Lock Turns off during boot

by curlergirl In reply to Num Lock Turns off during ...

Try loading (or reloading) SP6a. The only Technet article I could find about this referred to Terminal Server SP6 also, so if you are running TS, then load that service pack. The Numlock state is supposed to be saved when you log off, so if it's on when you log off, it should be on when you log back on. Supposedly the service pack fixes this if it's not working properly. Hope this helps!

Collapse -

Num Lock Turns off during boot

by jeffrey.grant In reply to Num Lock Turns off during ...
Collapse -

Num Lock Turns off during boot

by SyscoKid In reply to Num Lock Turns off during ...

1.Run Registry Editor.

2.Navigate to HKEY_USERS\.Default\Control Panel\Keyboard.

3.Change the value for InitialKeyboardIndicators from 0 to 2.

Collapse -

Num Lock Turns off during boot

by jeffrey.grant In reply to Num Lock Turns off during ...
Collapse -

Num Lock Turns off during boot

by jeffrey.grant In reply to Num Lock Turns off during ...

They are running SP4 nad can not run any higher.

Collapse -

Num Lock Turns off during boot

by jeffrey.grant In reply to Num Lock Turns off during ...
Collapse -

Num Lock Turns off during boot

by singhjunk In reply to Num Lock Turns off during ...

In Windows NT, the state of the NUM LOCK key is specific to each user, and is off by default.

The registry entries to enable NUM LOCK during logon.

Edit:

HKEY_Current_User\ControlPanel\Keyboard\InitialKeyboardIndicators

Type REG_SZ:

If set to 0, NumLock is disabled for that current user after logging on. If it is 2, NumLock is enabled and will retain the settings from the last shutdown.

To enable NUM LOCK during the CTRL+ALT+DELETE process, use Regedt32 to navigate to:

HKEY_USERS\.Default\Control Panel\Keyboard

Double click the InitialKeyboardIndicators value name, a type REG_SZ (string) value, and change the data value from the 0 to a 2.

Thanks,
jasjeet Singh

Collapse -

Num Lock Turns off during boot

by jeffrey.grant In reply to Num Lock Turns off during ...
Collapse -

Num Lock Turns off during boot

by TheWrightMan In reply to Num Lock Turns off during ...

Good day!

They say there are actually two ways to do this. One is to turn your num-lock on, then use the CTRL-ALT-DEL and Logoff or Shutdown button. This is supposed to save the num-lock setting in your personal registry. I have found that this does not work all the time. The other is to actually hack the registry yourself this way:

1. Start the registry editor (regedit.exe or regedt32.exe)
2. Navigate to HKEY_USERS\.DEFAULT\Control Panel\Keyboard
3. Edit the InitialKeyboardIndicators value
4. Set the value to 2 and click OK
5. Close the registry

When you reboot, the num-lock should be on.

Collapse -

Num Lock Turns off during boot

by jeffrey.grant In reply to Num Lock Turns off during ...
Back to Windows Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Operating Systems Forums