Discussions

On Citrix ICA connection setting default login to domain not workstation

Tags:
+
0 Votes
Locked

On Citrix ICA connection setting default login to domain not workstation

jhussey
I have a problem with Citrix ICA connections whereby when I attempt to make a connection to the published desktop the default login environment is set to the "Workstation (This computer)" rather than our companies Domain. In order to fix it I have to use the drop down box and select the ABC-CORP domain and then I can put in my credentials.

This possesses a real problem for our users because they cannot remember to use the drop down box and select the domain option before logging in.

How can I fix this so it always defaults to domain option instead of workstation.

Any help is greatly appreciated
  • +
    0 Votes
    nhdowning

    I have the same problem with W2k3 SP1 citrix server after reboot. Local admin logged in for maintenance and forgot to log back in with domain credentials. so the users could not figure out how to use the drop down box for the domain. Any solutions to this problem?

    +
    0 Votes
    PSer

    We use the Web Interface and do NOT publish desktops. However, you should be able to find a Policy that you can set the login to Domain option. GPO's, gpedit, etc.

    Don't have time to look right now myself ... just thought make a suggestion.

    +
    0 Votes
    johndees19

    I have the same problem, and I tired checking the GPO stuff, and it didn't seem to be there.

    +
    0 Votes
    latimer.law

    A. To set the default domain each time you log on, perform the following steps:

    Start a registry editor (e.g., regedit.exe).
    Navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon subkey.
    Double-click DefaultDomainName (or create this value of type String if it doesn't exist), and set the value to the preferred domain.
    Double-click AltDefaultDomainName (or create this value of type String if it doesn't exist), and set the value to the preferred domain.

    The domain will change back after reboot so you will need to write a batch file to run on boot up to edit those registry keys with the preferred domain.

    Hope this helps

    +
    0 Votes
    steven.bamford

    Hi there,

    A suggestion is to create an ica file from the published desktop in CMC, then edit the ICA file in notepad and under the section which shows the screen size settings etc, type a new line "Domain=<then type the domain name>.

    That will force the correct domain everytime.

    Just need to then rollout that icon for people to use instead, job done.

    Hope this helps!

  • +
    0 Votes
    nhdowning

    I have the same problem with W2k3 SP1 citrix server after reboot. Local admin logged in for maintenance and forgot to log back in with domain credentials. so the users could not figure out how to use the drop down box for the domain. Any solutions to this problem?

    +
    0 Votes
    PSer

    We use the Web Interface and do NOT publish desktops. However, you should be able to find a Policy that you can set the login to Domain option. GPO's, gpedit, etc.

    Don't have time to look right now myself ... just thought make a suggestion.

    +
    0 Votes
    johndees19

    I have the same problem, and I tired checking the GPO stuff, and it didn't seem to be there.

    +
    0 Votes
    latimer.law

    A. To set the default domain each time you log on, perform the following steps:

    Start a registry editor (e.g., regedit.exe).
    Navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon subkey.
    Double-click DefaultDomainName (or create this value of type String if it doesn't exist), and set the value to the preferred domain.
    Double-click AltDefaultDomainName (or create this value of type String if it doesn't exist), and set the value to the preferred domain.

    The domain will change back after reboot so you will need to write a batch file to run on boot up to edit those registry keys with the preferred domain.

    Hope this helps

    +
    0 Votes
    steven.bamford

    Hi there,

    A suggestion is to create an ica file from the published desktop in CMC, then edit the ICA file in notepad and under the section which shows the screen size settings etc, type a new line "Domain=<then type the domain name>.

    That will force the correct domain everytime.

    Just need to then rollout that icon for people to use instead, job done.

    Hope this helps!