General discussion

Locked

Open excel file with spaces in filename

By catalinro ·
When I double click on an Excel file with spaces in filename I get a series of errors.
Example:
If the file is called "My excel file.xls" I receive:

My.xls Could not be found. Check the spelling and the filename...
Excel.xls Could not be found. Check the spelling and the filename...
File.xls Could not be found. Check the spelling and the filename...

The same error for each word that can be found inside the name of the file.

At last he open the file but if he found for example a file from those he searched before he open that or those file to.

For example if I had on the computer Mywork.xls and Mywork 2.xls in the same directory and I double click Mywork 2.xls I recive the error 2.xls could not be found and both My work 2.xls and Mywork.xls are open.

How can I solve that?

Thanks.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by maxwell edison In reply to Open excel file with spac ...

Is this excel 2000?

I've seen reference to a similar bug in SR1 for Excel 2000 (Office 2000). If this is the case, install SR2. That fixed the bug.

If you have a different version of Excel, try the same thing -- install the latest service pack.

Workaround: Rename the file, and replace the blanks with an underscore ("_").

Collapse -

by DiamondJim22 In reply to Open excel file with spac ...

Try one or more of the ideas posted here:

http://www.geocities.com/budallen98_98/associatext.html

This answer was posted by BFilmFan yesterday.

Collapse -

by ReWrite In reply to Open excel file with spac ...

Check your file associations by following these steps:

Go to Start, Settings, Folder Options, File Types and scroll down to "Microsoft Excel Worksheet" Select it and hit the Properties button. In the lower window click on Open to select it and then click on Edit.

Application should show the path to excel.exe.

Below that place a check in the box for Use DDE if it is not already checked. In the DDE Message box use:
[open("%1")]

Below that for Application use Excel.

The [open("%1")] tells it to ignore the space in the name or should I say, look past the space.

Cheers.

RW

Back to Windows Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums