General discussion


Open Excel in Different Window

By ctmidnite ·
I have two monitors. It's very handy to be able to look at different sheets on different monitors. I can do this if I open two instances of Excel and then open different sheets but I haven't been able to get Excel to open in a seperate Window if I open another sheet from within the Excel window that I'm already viewing a sheet in.
Can I force Excel to always open in a new Window?

This conversation is currently closed to new comments.

52 total posts (Page 1 of 6)   01 | 02 | 03 | 04 | 05   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

It's in Options

by Tink! In reply to Open Excel in Different W ...

you didn't specify which version you are using but try looking under "Tools", "Options" and click the "View" tab.

Look for "Windows in Taskbar" and CHECK the checkbox.

Collapse -

Not quite.

by ctmidnite In reply to It's in Options

That puts two enteries in the taskbar but they are both located in the same window of Excel. If you try to drag one of two books you have open your bounderies are the Excel widow. You can't drag one of the books out onto the desk top. You can view them side by side but only in the same window.
If you open another book by first opening another instance of Excel then you have two Excel programs running and you can drag each program where ever you like.
I do this and it works fine, it's just that often I will have two books open before I realize I would like to view them at the same time.

Collapse -

I see

by Tink! In reply to Not quite.

I gotcha now. What you want is to have Excel open up another instance of itself when you open another sheet within Excel.

This is beyond my expertise. You will probably need to have one the of programmers here on TR see if they can work up a script for you.

Collapse -

Opening .xls &.xlsx Excel files in separate windows like you want to.

by Dcrandell In reply to Not quite.

I too have 200+ users that are annoyed by this so Today I tested and tested until i found a solid solution. The option in excel to ?Ignore other applications that use Dynamic Data Exchange (DDE)? does not work, but the following does.

Step 1: Open my computer and click on Tools/ Folder Options.

Step 2: Select File Types and find XLS as well as XLSX (you will edit one at a time with same info below).

Step 3: highlight .XLS Microsoft Office Excel 97-2003 Worksheet & Click the Advanced button and select the Open action followed by clicking Edit.

Step 4: Delete whatever is in the ?DDE Message box?.

Step 5: Add the syntax ?%1? (with preceding space and include the quotes!) to the end of any existing string in the ?Application used to perform action:? box. (if you skip this, file names that contain spaces will not open properly)

Step 6: Save and close all and give it a try!

Collapse -

Doesn't work in Windows 7 / Office 2007

by jiaailun In reply to Opening .xls &.xlsx Excel ...

It looks like this solution does not work in Windows 7. I'm still learning my way around the new interface, but I don't think you can get to the File Types dialog through Tools / Folder Options (now called Organize / Folder and Search Options). I've tried Control Panel / Programs / Default Programs / Set Associations, but there are no options for adding syntax or changing DDE messages.

I've also tried the solution posted elsewhere of checking the "Ignore other applications that use Dynamic Data Exchange (DDE)" in Excel Office Button / Excel Options / Advanced / General. In this case double clicking a file causes Excel to start a new instance, followed by an error message, and no file is loaded.

For now I'm living with the workaround of starting a new instance manually, and then opening the file manually in that new instance. I'd like to have a simpler way though. What good are multiple monitors when all your files open in one window?!

Collapse -

XP, Vista, Win7 Solution

by mrtsherman In reply to Doesn't work in Windows 7 ...

This Excel issue has driven me bonkers for years so I've written a little helper app that solves this problem across all MS OS's. You can download and read up on it at my website.

Collapse -

Problems with this solution

by klecon In reply to Opening .xls &.xlsx Excel ...

This code change worked as expected - except when trying to edit excel sheets from Sharepoint the excel workbook gets thrown to MS Word!

So, I tried to undo the code change and at the end of the Application used to peform action, I keep getting "C:\Program Files\Microsoft Office\Office12\EXCEL.EXE" /e %1

No matter what - it keeps coming back. Now when I try to open Exel sheets, I get a lot of different errors.

Any help?

Collapse -

Office Excel 2010 Win7 Solution

by Kentonj123 In reply to Problems with this soluti ...

I was searching for a similar solution and the fix for prior version of office

did not work for Win7. I made some changes and found a way to make it work.

Please read entire post before attempting.

Works for
Excel 2010 & Win7 (could work for 07 not tested)

Open Registry Editor ver6.1

-Go to Branch:

(Note: it doesn't matter what is listed under default)

-Change the value command and under data remove /dde and add below

/p "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" /e "%1"

(Note: /p switch will ignore the (default) open settings)

-Go to Branch:

-Rename ddeexec2

-Closing: Repeat for Excel.Sheet.8 with a similar change and make sure your

file locations are properly linked if installed in a different directory. I

found that windows updates undo this change in prior versions. It may be

necessary to have a registry update to keep the change in place.

Hope you are successful and always backup your registry before changing.

Collapse -

Office Excel 2010 Win7 Solution

by dpaq In reply to Office Excel 2010 Win7 So ...

that works perfectly - thanks. as Kentonj123 take care where the path is to the exe i.e. my path file is C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE as i am running win7 32 bit.

Collapse -

That worked!

by Hayyward In reply to Opening .xls &.xlsx Excel ...

Thank you very much, that drove me crazy!!

Back to Community Forum
52 total posts (Page 1 of 6)   01 | 02 | 03 | 04 | 05   Next

General Discussion Forums