id="info"

General discussion

Locked

Outlook Address Autocomplete issue

By cshrake ·
I'm having a problem with a customer who is using Outlook 2002 on a Windows 2000 Terminal server.

Recently, the email autocomplete used to offer suggestions for matching email addresses in Outlook suddenly stopped working. When the customer begins to type the email address into the TO field, no suggestions display (as if the history has been lost).

I located the NK2 file for the user's Outlook Profile (located in C:\Documents and Settings\**UserID**\Application Data\Microsoft\Outlook). Using INGRESSOR, I was able to open the user's NK2 file, and see all of the entries in the file, so i do not believe the file is corrupt. I rebuilt the user's Outlook profile, then re-added the NK2 file (making sure to rename the NK2 file to match the profiles name), and had no luck. I found an old copy of the NK2 file from 4 months back that we know for sure is not corrupt, but still problems persist.

In Outlook (under the Options menu), the option for "Suggest names while completing To, Cc, and Bcc fields" is enabled. We even tried doing an Outlook "Detect and Repair", and an Office Re-install, yet cannot resolve the issue.

I spent nearly a day looking for a solution to this problem, and cannot find a solution. No one else on the terminal server is having this issue, just this one person.

Anyone know how to resolve this?

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Resolution

by cshrake In reply to Outlook Address Autocompl ...

In a last ditch effort to attempt resolving this issue, I retried a previous step (with a twist):

I went into this directory:

C:\Documents and Settings\**UserID**\Application Data\Microsoft\Outlook

I then deleted all files located here (while Outlook was not running for that user).

I then reopened Outlook, which recreated the files:

Profilename.FAV
Profilename.NK2
Profilename.srs

I then sent a message from the users email account, and then tried another one, to verify the email address saved. The Autocomplete remembered the recipient.

I then closed Outlook again, and re-deleted all files in the before mentioned directory.

I then copied the old NK2 file back in, and renamed it identically to the Outlook profile name.

I then restarted Outlook, and the Autocomplete is now showing the addresses stored in the NK2 file.

Not sure why that worked when previous attempts had not, but figured I'd share this experience with everyone.

Collapse -

Thanks!

by JAStillwell In reply to Resolution

I have a client with the same problem and this solution worked the first time!

Very cool!

Thanks,

Jeff

Collapse -

It worked

by techrepublic In reply to Resolution

It was my own Outlook that stopped auto-completing. I copied that nk2 file out of the mentioned directory and deleted everything else, opened Outlook, sent a test message and the address was saved when trying to send a following message. I then replaced the newly created nk2 file with the one I copied out, re-opened Outlook and it works like a charm.

Thank you to the person that posted his fix. Half the time people filed their answer and never bother posting back so thanks again.

Collapse -

Thanks!!!

by smackerindignity In reply to Resolution

Worked for me, but anyone have any idea WHY this happenned or why this works?

Collapse -

Thanks

by NDS84 In reply to Resolution

This is great, thanks. Can you say "saved me a headache"

Collapse -

Thanks, sort of worked

by techrepublic In reply to Resolution

Thanks for the solution, the file I'm dealing with is obviously corrupt though because it's only picking up the first three entries of many.

Opened the file with NK2View <http://www.nirsoft.net/utils/outlook_nk2_autocomplete.html> hoping I might be able to export them and re-import them but it also only showed the first three. Seems one/some of the random looking ASCII characters is wrong, managed to remove different entries around and including the third one but others following still didn't show up...

Collapse -

A simple resolve

by mitch In reply to Resolution

Just following the logic above ... I tried a varied approach. In Outlook / Advanced E-mail Option, I unchecked 'Automatic name checking' and 'Suggest names while completing To, CC, and BCC fields'. Then I quit Outlook and restarted Outlook. Next I just re-checked the same options back on. After that the Auto-complete worked. Worked for me.

*Mitch@dbqstamp.com*

Collapse -

Worked a treat!! Thanks

by alan.t.kelly In reply to Resolution

Followed steps exactly - worked for me too!

Collapse -

You rule!

by jonah In reply to Resolution

You made me look like a hero!

Collapse -

Still going strong!

by john In reply to Resolution

Your solution made my client's day! Even after 4+ years, your advice is still working. Thanks for taking the time to post!

Back to Software Forum
10 total posts (Page 1 of 1)  

Software Forums