General discussion

Locked

Problem with WinXP ICS

By R. A. Caluste ·
I have the ff setup:

1 multihomed WinXP PC connected to the internet via Cable Modem, and to the lan via Switch.
Used the network setup wizard to configure Internet Connection Sharing.

When I ping my default gateway (public interface), I could not get a response (request timed out). When I ping a pc in my LAN (private interface), i get a response ( < 1 ms). When I disable my private interface (the connection to my private lan), I am able to ping my internet gateway. As soon as I enable my private interface, the ping status to my public gateway foes from 15 ms to 1000 ms to 2000 ms to request timed out.

Before it was working properly, now, I cannot make it work. I have reset my winsock (using winsockfix, netsh int ip reset x.log).

Netdiag returns error when trying to ping default gateway.

Any ideas?

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by rindi1 In reply to Problem with WinXP ICS

The default gateway on the pc which is sharing the internet connection should not be set by you (You are probably using dhcp to get an ip address from your cablemodem, you'll get the gateway from there). The connected PCs should have your PCs IP address as gateway address. That way it should work.

Collapse -

by R. A. Caluste In reply to

Thank you for your answer.

I have not set any configuration manually.

The public interface configuration was obtained dynamically using the ISP's DHCP.

The private interface configuration was obtained automatically using the network setup wizard ( when using ICS on WinXP, the private interface is automatically assigned the IP address 192.168.0.1, netmask 255.255.255.0)

From the PC sharing the internet's console, I am able to ping the workstations connected in the LAN. However, I cannot ping my ISP's gateway. If I disable my private interface, I am able to ping my ISP's gateway. Why is that?

Collapse -

by mikex In reply to Problem with WinXP ICS

Buy a router and connect them in the following order:

Cable modem=>Router=>Switch=PC's

Collapse -

by R. A. Caluste In reply to

I was hoping for a solution using Windows XP and ICS. I have used this before and is puzzled as to what went wrong with my present configuration.

Thanks.

Collapse -

by R. A. Caluste In reply to Problem with WinXP ICS

Point value changed by question poster.

Collapse -

by candi_sd In reply to Problem with WinXP ICS

1. Remove ICS
- You should not need ICS to access internal and external network at the same time. I understand that you are trying to share the connection out, but this is just to troubleshoot the connection first. Does this solve your problem? If not see step 2.
2. Ping the internal and external gateway. If you do not have an internal gateway then try to ping a another computer in your subnet. If you are able to ping internally and externally then you may have a bad network cable or something with the hardware, but your configuration will be fine. It doesn't sound like this is the problem you are having. If you are unable to ping both gateways then it is a configuration problem see step 3.
3. Verify IP address you are pinging are in your subnet. Make sure the gateway and the device you are trying to ping are in your subnet. If you need help with this you can post your configuration and I can help you verify it. If your network configuration is correct then check out step 4.
4. Remove TCP/IP stack and reinstall then uninstall and reinstall new device drivers for your network adapters.
If none of these steps resolve this issue then post your results and we can go from there.

Collapse -

by rindi1 In reply to Problem with WinXP ICS

Can you open a command prompt on your gateway pc and execute "ipconfig /all" (without the quotes), then reject my answer and paste the result you get here?

Thanks.

Collapse -

by mikex In reply to Problem with WinXP ICS

In order for you to get a working config with the following:

cable modem=>Switch=>PC's

you need to have on the ICS PC TWO network cards

the first one needs to be associated with your cable modem to receive the Internet (your cable ISP is controling your access with your netCard MAC address) - so it's dedicated one

Open the network connections and Bridge the 1 netCard with the second one and plug the NetCable from the second card into the switch => GO&Surf

Collapse -

by dustyD In reply to Problem with WinXP ICS

Another way to resolve:
Using static IP addressing, only 1 NIC is required. DSL modem/Router/Lan PC's.
Make sure that each PC's IP address is in the same range as your router.
Routers by default are mostly 192.168.1.1 When you enable ICS, Windows changes your IP to 192.168.0.1 Enable NAT, disable DHCP on the router. Your router still hides local LAN behind its public IP address.
Ensure unique PC names, using identical workgroup name. You should have no problems with internet connection and sharing files/printers.

Collapse -

by dustyD In reply to

To clarify, there should be no ICS connections on your PC. The only connection listed should be your NIC, do dial-up connections required, no bridging.

Back to Windows Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums