Question

  • Creator
    Topic
  • #2137010

    QOS Problem on Cisco 878

    Locked

    by fandre22 ·

    Tags: 

    Hello,
    I encounter some difficulties to set a QOS which enables to free space for default-class, when Priority queues are empty.

    Here is the configuration I’ve made :

    ===================================================
    access-list 199 remark equipements VOIP
    access-list 199 permit ip 192.168.1.0 0.0.0.255 any
    access-list 199 deny ip any any

    access-list 198 remark equipements VISIO
    access-list 198 permit ip 192.168.2.0 0.0.0.255 any
    access-list 198 deny ip any any

    class-map match-all voip
    match access-group 199
    class-map match-all prec-voip
    match ip precedence 5
    class-map match-all visio
    match access-group 198
    class-map match-all prec-visio
    match ip precedence 4

    !
    !
    policy-map QOS
    class prec-voip
    priority 200
    class prec-visio
    priority 200
    class class-default
    bandwitdh percent 20
    random-detect

    policy-map tag
    class voip
    set ip precedence 5
    class visio
    set ip precedence 4

    interface vlan1
    service-policy input tag

    interface dialer0
    bandwidth 512
    service-policy output QOS
    ===================================================

    The service policy has no effect on traffic (with show policy-map int dia0)
    I’ve also tried to apply service-policy on ATM0, but it’s impossible to do it when we use encapsulation aal5mux ppp dialer.

    I’ve also tried to make this configuration , but no effect :
    =============================================

    Device(config)# policy-map childExample
    Device(config-pmap)# class voice
    Device(config-pmap-c)# priority percent 30
    Device(config-pmap-c)# exit

    Device(config-pmap)# class video
    Device(config-pmap-c)# bandwidth percent 50
    Device(config-pmap-c)# exit

    Device(config-pmap)# class class-default
    Device(config-pmap-c)# fair-queue
    Device(config-pmap-c)# exit

    Device(config)# policy-map parent
    Device(config-pmap)# class class-default
    Device(config-pmap-c)# shape average 1000000
    Device(config-pmap-c)# service-policy child
    Device(config-pmap-c)# exit

    Device(config)# interface dialer 0
    Device(config-if)# service-policy output parent
    =============================================

    Here is the IOS version used :c870-advipservicesk9-mz.124-24.T2.bin
    Do you know if there some improvements in QOS with newest IOS versions ?

    Thanks in advance for any help on this topic.

All Answers

  • Author
    Replies
Viewing 0 reply threads