General discussion

Locked

Read-only property attribute XP Folders

By generator ·
When in XP's Windows explorer, whenever I highlight a directory, right click select properties it displays the various specifics about the target directory. Under Attributes, the box next to READ-ONLY is always highlighted green. I can click on the box to remove the green, click again to place a "check" in the box but whenever I remove the green and save the setting it returns the next time I view the properties of the directory.

I'm troubleshooting a software problem and must allow all users complete rights to two directories. Symptoms all point to user rights restrictions. In all earlier iterations of Windows, I've been able to apply object rights to the target directories, specifically allowing all users every right except administrator. I'd like to understand the distinctions between the three "toggled" options on the read only box.
1) filled with green ???
2) empty (presumably designates NOT read only)
3) checked (presumably designates read only)

Thanks for any help sorting this out. I've had no luck on MS Knowledgbase, or in various discussion groups.

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by generator In reply to Read-only property attrib ...

Point value changed by question poster.

Collapse -

by razz2 In reply to Read-only property attrib ...

Check boxes have three values: On, Off, Mixed

Let's assume you have a Dir with two sub-directories. Each sub
has two text files as follows:

Main DIR
_______
|
Sub Dir 1
__________
|
Text File 1 (Read Only)
Text File 2 (Read Only)

Sub Dir 2
__________
|
Text File 3
Text File 4

The Main would show the mixed box you called green because
some contents are read only and some are not.

Sub 1 would be checked as all contents are read only.

Sub 2 would be unchecked as nothing is read only.

If you try to change the Main Dir to NOT checked it will ask if it
should apply to just that folder or that folder AND SubFolders
and Files.

razz

Collapse -

by generator In reply to

Sounds logical but does not prove to be true. I tested with a directory containing only two files. Neither file was "read-only". Selected directory, properties, unchecked the green box, APPLY button, chose to apply to all subdirectories and files. When I returned to the properties of the directory, it still showed GREEN on Read-Only attribute box. Hmmm.... Thanks, though!

Collapse -

by willcomp In reply to Read-only property attrib ...

I believe the green box means that folder is read only to some users but allowed for current user. That's empirical observation, not an absolute.

I believe what you wish to do is set special permissions for folders requiring global access. In interest of saving time and typing:

Search for "Folder Special Permission" (without quotes) in Windows XP Help (Start -> Help and Support). Instructios provided are straight forward.

Hope that's what you need.

Dalton

Collapse -

by generator In reply to

Thanks Dalton, I tried this method. It may well provide the users access to the files, but it appears to have no impact on the status of the read-only attribute box. It still remains green.

Collapse -

by TheChas In reply to Read-only property attrib ...

This is one of the things I like about this forum, a chance to learn something new.

I found a lot of interesting information on Microsoft's web site.

What is pertinent here is that it looks like the "green" read attribute is an inherited "child" permission.

To fully disable the read only attribute, you need to disable simple file sharing in folder options.

Then, on the security tab for the folder in question, you need to disable inheritance.

Then, you should have full control over the folder attributes.

Chas

Collapse -

by generator In reply to

Again, this sounds perfectly logical, but does not prove effective in "eliminating" the green box. I tested with a directory containing two files (neither explicitly marked as read-only). Rightclick on the folder, properties, shows green box. Open folder, View, Folder Options, Uncheck USE SIMNPLE FILE SHARING (Recommended). Backed up to highlight the folder, rightclicked selecting Properties, (still green) then I selected Security and disabled inheritance. Applied special permissions, selecting group everyone and explicitely allowed all rights. After application, Properties of the directory still shows "GREEN"???

Collapse -

by rindi1 In reply to Read-only property attrib ...

A green folder usually indicates the folder to be encrypted. Right click the folder as administrator or user who is the owner of the folder, select properties, advanced and uncheck the box "encrypt to secure data" if you want to decrypt the folder, or click on details to add those users (groups) who need access (the folder will then stay green).

Collapse -

by Omnicef In reply to Read-only property attrib ...

One of these articles should be what you need.

Unable to Remove Read-Only Attribute from Folder
http://support.microsoft.com/default.aspx?scid=kb;en-us;256614

You Cannot View or Change the Read-Only or System Attribute of Folders
http://support.microsoft.com/default.aspx?scid=kb;en-us;326549

Collapse -

by treillian In reply to Read-only property attrib ...

Microsoft has a fix for this problem, although I don't know if it will work for you or not, but it is worth a shot.

http://support.microsoft.com/default.aspx?scid=kb;en-us;256614

Good Luck :-)

Back to Windows Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums