General discussion

Locked

Red Hat, Samba and Windows Problem

By BikerGeek ·
Sometimes, when we try to access our RH6.2 box which is running Samba, we get a message stating the server is not accessible - No permission to access resource. This is a winders error. You can still see the Samba mount in Network Neighborhood. To remedy this, we have to do one or both of the following: 1. Reboot the winders machine. 2. Restart Samba. I am not sure if this is a Samba config issue or a winders networking issue. Any ideas? Thanks!

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Red Hat, Samba and Windows Problem

by jay In reply to Red Hat, Samba and Window ...

First, look at samba log and message, you can find any clue on this log.
Check entire network, maybe there's another samba server with the same configuration. Maybe there's conflict problem with WINS or DOMAIN logon.
Try recompile Samba from source or SRPMS.

Collapse -

Red Hat, Samba and Windows Problem

by BikerGeek In reply to Red Hat, Samba and Window ...

Jay - thanks for the reply! In the samba log, it always states that the user's ID is rejected - even when the connection is successful. I have all users aliased to one samba-only user. This is the only samba server on my network. I am not sure abouta WINS or DOMAIN logon - I'm still learning MS networking. If all else fails, I will recompile my samba source. Thanks!

Collapse -

Red Hat, Samba and Windows Problem

by jist In reply to Red Hat, Samba and Window ...

Be sure that the user who is logging into Windows has an account on your linuxmachine.

Collapse -

Red Hat, Samba and Windows Problem

by BikerGeek In reply to Red Hat, Samba and Window ...

Thanks for the reply! All users connecting to the samba box are being aliased to one samba-only user.

Collapse -

Red Hat, Samba and Windows Problem

by Bruce Timberlake In reply to Red Hat, Samba and Window ...

Make sure that both the Samba server and the Windows workstation know about each other via DNS. As a pinch fix, you can edit the /etc/hosts file on the Samba box and make an entry for the Windows workstation. Depending on how you set up the Samba share, you may need to be logged onto the Windows box with the same username as the owner of the Samba share. (In smb.conf, try setting "guest ok" to "yes" for the share in question; that will temporarily allow you to connect with any username.)

Collapse -

Red Hat, Samba and Windows Problem

by BikerGeek In reply to Red Hat, Samba and Window ...

Bruce - thanks for your input! As it is, all Winders workstations on the LAN are listed in /etc/hosts. Also, all users are aliased to one common 'guest' account. And since after a reboot of the Winders machine and/or restarting samba things work OK,I am not sure where to look.

Thanks again!

Collapse -

Red Hat, Samba and Windows Problem

Hi!

I'm guessing you have a DOMAIN controller or two and that you are running WINS, if this is the case I'd remove the hosts files, they'll might mess things up with windows naming scheme.

In smb.conf make sure you have the following:
netbisoname = [name you want win machines to recognize your samba server by]

Now samba will register with wins just like all other windows machines and broadcasting it's name onto the network.

workgroup = [either your workgroup or your NT Domain]

This ensures it will turn up in the right place in network neighbourhood.

local master = no
If you running domain and/or wins this ensures that samba dosen't start a browser war. Only one windows NT Workstation, Windows NT Server or Samba server can hold your network browser list.

os level = 20

;determines the precedence in which computers try to become master browser this ensures it won't be samba server.

/Hasse

Collapse -

Red Hat, Samba and Windows Problem

Hi!

I was afraid I woul run out of space!

If you done all things above and you still experience problems my last suggestion might help.

Read the samba HOWTO on creating a COMPUTER ACCOUNT for the samba server and let the samba server join the domain, this way it will be in the PDCs browser list.

/Hasse

Collapse -

Red Hat, Samba and Windows Problem

by BikerGeek In reply to Red Hat, Samba and Window ...

The question was auto-closed by TechRepublic

Collapse -

Red Hat, Samba and Windows Problem

by brianbarber In reply to Red Hat, Samba and Window ...

I would encounter the same probelem until I put the IP address of the Samba machine (which happens to be my WINS server as well) in the WINS configuration tab on the client machine. If that solves it, included the WINS info in DHCP so that all yourusers get it automatically.

Cheers,
BB

Back to Linux Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Operating Systems Forums