General discussion

Locked

remote desktop support

By friscojw ·
I would like to remotely access a desktop and have not been successful. I understand if a router is involved port 3389 needs to be forwarded, but what is is just a modem supplied by the cable or DSL company?
Can it be done easily? Do I need to use Microsoft VPN?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Sue T In reply to remote desktop support

I don't know if this will help or not but I use VNC which is a free program for remote desktop ( I tried Ultra VNC but that did not work well for me so I down graded to Real). I had to tell Windows firewall to allow this program in exceptions. We also use Windows Remote Desktop for people who need to run a program that resides on a server and the only thing I remember doing there was setting up user accounts for them on that server and changing some permissions.

Collapse -

by TechKid In reply to remote desktop support

use xp's help to find out how to turn remote desktop on for the computer you wish to connect to

Then use the RD client to type in your outside ip address and click connect.

Collapse -

by dryflies In reply to remote desktop support

If your ISP gives you a routable address you do not have to do any port forwarding. make sure your firewall is allowing port 3389 - limited to the ip for the remote computer you want to use to access your desktop. Next, right click my computer, select properties, and then in the remote tab, select allow users to connect remotely to this computer. Thhen click the "select remote users" button and give permission for remote access as desired.
routable address -- go to a command prompt and execute "ipconfig /all" find your ip address. if it is 192.168.*.* or 10.*.*.* you do not have a routable address and will have to set up port forwarding. for DSL, you may have a router that is doing NAT for you and it is where you will set your port forwarding. if portforwarding occurs at the ISP you may have more trouble. the ISP may not want to forward all 3389 traffic to you. You may be able to convince them to forward port 3389 from a specific IP to your computer.

please rate my answer

Collapse -

by jonno112 In reply to remote desktop support

I use vnc which is cool.

Depending what sort of router you have it,s generally called Nat or Pat.

But what you need to do is get into your modem through the web interface, port 3389 needs to be forwarded to the ip address that you want to remote into.

If running XPSP2 you might have to enable port 3389 through.

Collapse -

by p.mears In reply to remote desktop support

There are a number of things to consider here

1. For Remote Desktop, you MUST be running XP Pro - XP Home does not allow RD.

2. To log into Remote Desktop, the user account must be configured for access. Members of the Administrators group are automatically permitted. To add additional access, go to the Remote tab of MY COMPUTER properties and click "Select Remote Users".

3. Remote Desktop must be allowed in Windows Firewall if using XPSP2. This will open up incoming connections to port 3389.

4. If accessing through a router, port 3389 must be forwarded to local address.

5. If you are using a NAT router, most will only allow you to forward 3389 to a single address. If you have more than one machine that you want to remotely access, you need to change the port that RD uses. In registry, goto HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber and change the value (ie from 3389 to 3390). If you are doing this you will also have to allow that port in Windows Firewall. In the NAT router forward 3390 to the appropriate computer. Repeat using unique port numbers for each additional computer. When connecting to computer, using x.x.x.x:3390 to connect (otherwise 3389 will be used by default)

6. Windows XP remote desktop does not allow for interactive Remote Desktop. For this, users will have to send a Remote Assistance request (whole new can of worms), or, as noted above, a program like VNC is suggested.

7. VNC uses by default port 5900. Windows Firewall and routers will need to be configured in the same fashion to allow for 5900 to be forwarded to the computer.

8. If more than one VNC machine, change port 5900 to 5901, 5902, etc...VNC also refers to these as Screens. Access them using x.x.x.x:5901 - Again windows firewall needs to be told to specifically allow port 5901, 5902, etc.

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums