Question

Locked

Roaming profiles (locally set as Power User) no access to HKEY_CURRENT_USER

By willmisc ·
I recently copied several workstation profiles to a network share, making them roaming profiles. The roaming profiles work, but unless the roaming profiles are locally set as Administrators (which I don't want), they do not have any write access to the HKEY_CURRENT_USER hive in the registry. This means that these users have no ability to personalize their desktops (theme, wallpaper, recent items in the start menu, etc...). They can access Display Properties and select a wallpaper, but when they click OK, nothing changes. I ran regedit under a roaming profile and right-clicked HKEY_CURRENT_USER, hit Permissions, checked "Full Control" for Power Users, and hit OK, it said, "Unable to save permission changes on HKEY_CURRENT_USER. Access is denied." I logged in as a local Administrator, granted Power Users Full Control for HKEY_CURRENT_USER, but when I log back into the roaming profile (which is locally a Power User), nothing changed. How do I grant Power Users access to their own registries?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Same sort of issue

by ih8computers.911 In reply to Roaming profiles (locally ...

I have the same sort of issue but a little different. We want to restrict a key within HKCU from being created. Does anyone have any idea?

Collapse -

Add user to regeit HKEY_CURRENT_USER

by mlibanio In reply to Roaming profiles (locally ...

As the title implies, add the user as well to the registry HKEY_CURRENT_USER. Then add the user as a local user as Power User. This will resolve the issues. This was plauging me for 4 months. Problem solved!

Back to Windows Forum
3 total posts (Page 1 of 1)  

Operating Systems Forums