General discussion

Locked

SCO UNIX changing default dev permission

By scottk ·
When you enable /devtty1* or /dev/tty2* the default permissions are set to: crw-------

You can change those with chmod, but when you disable and enable it again they default back to: crw-------

How do you change those default permissions. I have been told there is a file you can edit, but I don't know what the file name is.

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

SCO UNIX changing default dev permission

by bowieb In reply to SCO UNIX changing default ...

According to SCO's website, those permissions are set to conform to security specs and shouldn't need to be changed. See this webpage:
http://www.sco.com/cgi-bin/ssl_reference?106210.shtml

There are a set of permissions in /etc/perms/rtsmd (in SCO 3.2v4.2), but they will only be used when you run fixperm and the enable command will change it back to 600 for you.

Is this causing a problem for you? Perhaps if you described the problem, I could help you find away around it.

Collapse -

SCO UNIX changing default dev permission

by scottk In reply to SCO UNIX changing default ...

Poster rated this answer

Collapse -

SCO UNIX changing default dev permission

by hernando_garcia In reply to SCO UNIX changing default ...

Using command chmod

Collapse -

SCO UNIX changing default dev permission

by scottk In reply to SCO UNIX changing default ...

Poster rated this answer

Collapse -

SCO UNIX changing default dev permission

by johan In reply to SCO UNIX changing default ...

In SCO's /etc/default directory there are a lot of default settings for various devices. Look around in it. This might give you the answer

Collapse -

SCO UNIX changing default dev permission

by scottk In reply to SCO UNIX changing default ...

Poster rated this answer

Collapse -

SCO UNIX changing default dev permission

by roger.gibson In reply to SCO UNIX changing default ...

I had the same problem. I solved it by creating a file in the /etc/rc2.d directory that sets it up automatically. I haven't had to mess with it since I did this.

I created a file called Schmodtty2A. Below are the contents:
#
# set permissions and ownership for use by the remote login
#
#
chmod 666 /dev/tty2A
chown bin:terminal /dev/tty2A

Hope this helps.

Collapse -

SCO UNIX changing default dev permission

by scottk In reply to SCO UNIX changing default ...

The question was auto-closed by TechRepublic

Collapse -

SCO UNIX changing default dev permission

by Conrad In reply to SCO UNIX changing default ...

Knowledge Three things are necessary for the salvation of man: to know what he ought to believe; to know what he ought to desire; and to know what he ought to do.

- St. Thomas Aquinas Two Precepts of Charity.

Collapse -

SCO UNIX changing default dev permission

by scottk In reply to SCO UNIX changing default ...

The question was auto-closed by TechRepublic

Back to Linux Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums