General discussion

Locked

Server Woes

By sharphillips ·
I installed a second server on a one server network, joined the domain, promoted it to Primary and demoted the old Primary. Then I gave the old server a new name and renamed the new one to the name of the old one as someone suggested to me here in a previous question.

Now the old primary says "access denied" when I try to run Server Manager. Server Manager on the new server shows both servers, but when I check "Show Domain Members Only" the only server that shows up is the old one. When I try to add the new server to the domain it says that a machine account for the new server already exists. I don't understand why I can even run Server Manager when the computer apparently isn't a member of the domain. How do I resolve this and get the two servers to work together?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Server Woes

by Tech Bob In reply to Server Woes

I have found that the best way to prevent "access denied" problems when changing server names is to: 1. Remove the server from the domain and add it to a workgroup. 2. Reboot the server. 3. Rename the server. 4. Reboot the server. 5. Rejoin the domain.

Collapse -

Server Woes

by sharphillips In reply to Server Woes

Poster rated this answer

Collapse -

Server Woes

by toolkit In reply to Server Woes

I agree to the approach. NT saves the SID as a cobination of computername and domain/workgroup. As long as you keep the old setup, the system thinks it is an unknowm machine, because the SID information does not match anymore with the saved info. Bychanging into a workgroup and rejoining (and creating a workstation account of course), you will get the new SID on the primary.

Collapse -

Server Woes

by sharphillips In reply to Server Woes

Poster rated this answer

Collapse -

Server Woes

by sharphillips In reply to Server Woes

This question was closed by the author

Back to Windows Forum
5 total posts (Page 1 of 1)  

Operating Systems Forums