Question

Locked

Shared Network Folder Rights\Permissions

By MKRives ·
I have an existing Network Folder, let's call it Test. Test has Full rights for the group, Everyone. Everyone contains all company users. I need to give rights to only two individual users for Test folder and deny rights to the Everyone group. The problem is that the two individual users are also listed in Everyone group and despite the fact that I have given them individual Full Rights, when I deny Everyone group, access is also denied for them. How do I need to make this change?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Don't deny 'everyone'

by NexS In reply to Shared Network Folder Rig ...

Firstly, to keep things neat, create a security group for the users which have access (makes it easier when delegating more people/more places).

Don't deny the group 'Everyone'. Just don't add it in there at all, but add your new group and give 'Modify' or 'Full Control'.

Collapse -

Everyone is auto added

by MKRives In reply to Don't deny 'everyone'

When the new folder is created the group Everyone is automatically added to the folder as the Parent owner....

Collapse -

the everyone group is literally everyone, including the pet dog

by CG IT In reply to Everyone is auto added

and the neighbor down the street.

In the share permissions, you add those users you want to access the share, assign the level of permissions, remove the everyone group.

only those on the share list will be able to access the share.

note: if this is a workgroup setting, the users that are granted access must have an account on the machine the share resides on. This is because authentication to access the share is done on the local machine's users and groups database.

Collapse -

Resolved - Removed Inheritable Permissions

by MKRives In reply to the everyone group is lit ...

I found my problem. I went in and removed "Allow inheritable permissions from the parent to propagate to this object and all child objects." Then I was able to remove Everyone group and then the two individual users (with different permissions) permissions worked correctly.

Collapse -

Document You Network Shares

by LiveNDieN LA In reply to Resolved - Removed Inher ...

MKRives,
I know how frustrating it is to set up security for shares. The shares are requested usually when you are at your busiest and they start to accumulate across your servers.
After have a file server crash several times I finally put together a document that specifies each network share. This is what I did.
First I write down the path:
\\Server1\PublicShare
Then i created a table with three columns in MS Word.
Column 1= Users or groups
Column 2 Shares= Fill in permissions Full-Read -Write
Column3 Security= Fill in security permissions.

This has helped me rebuild file servers already on at least three occasions, saving me hours of work. Its also great when you want to consolidate shares or migrate to another server.

Good Luck!

Collapse -

Excellent to hear

by NexS In reply to Resolved - Removed Inher ...

Nice work.

Back to Software Forum
7 total posts (Page 1 of 1)  

Software Forums