General discussion

Locked

SMABA Not Accessible from NT

By m_jamshaid ·
I am using Redhat Linux 7.0 as well as NT 4.0. Under NT PDC I have establish a SAMABA file server on Linux machine. Window NT Users can see this machine in browser. But SAMBA server does not allow them to logon from NT machines. It displays the message ?The account is not authorizing to logon from this station.?
Here is brief history what I did.
1- Users have accounts on SAMBA server.
2- Also defined in smbpasswd
3- Users are allowed to access shares in smb.conf.
4- SMABA machine is working as well as other workgroup.
5- They can telnet SAMBA server.

So I have made changes in registry of NT machines as under

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Rdr\Parameters
DWORD Value
EnablePlaneTextPassword 1

Those machines, which got these changes, can access through username & password but for others SAMBA is still unavailable.What is the solution??

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

SMABA Not Accessible from NT

by plau965072 In reply to SMABA Not Accessible from ...

The way you get it to work is to make NT machine use un-encrypted password. This is OK as long as security is not one of your concern. Reading from some SAMBA related literature, I found that NT4 and Win9x (starting from Win95 OSR2) uses encryptedpassword by default. Instead of updating all NT machines to use un-encrypted password, you can make samba recognize encrypted password by add the following lines under [global] section of the /etc/smb.conf file:
hosts allow = <your netmask, suchas 192.99.111 for IPs 192.99.111.1 - 192.99.111.255>
workgroup = <whatever your NT domain name or workgroup name is>
encrypt passwords = yes
password level = 20

make sure you activate this settings before you test them:

/etc/rc.d/init.d/smb stop
/etc/rc.d/init.d/smb start

This should get all users that has a smb password to be able to log onto the samba server (except the ones who has a pre Win95 OSR2 workstation).

I have yet to find an elegant solution to share thesamba server files with an option like that of NT, where permission to the samba files can be set to all-user to allow all users (with/without the proper smb password) to access the samba files. If anyone know, please tell me. Thanks.

Hope this help

more help from the web:
http://eunuchs.org/linux/samba/index.html

Collapse -

SMABA Not Accessible from NT

by m_jamshaid In reply to SMABA Not Accessible from ...

Poster rated this answer

Collapse -

SMABA Not Accessible from NT

by Gregory Pleau In reply to SMABA Not Accessible from ...

There are two ways to go from here:

If you are trying to use the NT Server to authenticate users on the SAMBA box, be sure to put

security = domain
or
security = server

in your smb.conf file.

HOWEVER: If you are trying to use Sambaas the PDC itself (as in no NT Server) there is a slightly different method:

Security should be "security = user" and encrypted passwords should be ON in the smb.conf instead of the registry hacks you have above.

1) I've only tried this on Samba 2.2.0-alpha series builds as these are the first to support it 'officially'. (www.samba.org)

2) Create a group called 'machines'

3) At the bash prompt, type:
adduser -c NT Machine -s /bin/false -g machines -d /dev/null (computername)$

4)Again at the bash prompt, type:
smbpasswd -a -m (computername)

5) At the NT computer, quit the domain, then rejoin the domain - DO NOT create a computer account.

6) Be sure to create a Netlogon folder, use 775 for permissions. Create a Profiles share and I use 777 for that folder, you might want to try a different value

The NT computers will be able to view the domain user list and access resources on the server. I'm pretty sure this will require the encryption be turned back on, but you should try it either way.

Collapse -

SMABA Not Accessible from NT

by m_jamshaid In reply to SMABA Not Accessible from ...

Poster rated this answer

Collapse -

SMABA Not Accessible from NT

by Lintadsl In reply to SMABA Not Accessible from ...

You can have all domain user can log in to Smb file server with out puting a password.
Add a line "securty = share" in global section.

This is what I use for our LAN user. Of course, I set hosts.allow/deny that all local machine can access the server, not OUTSIDE.

Have a fun.

Collapse -

SMABA Not Accessible from NT

by m_jamshaid In reply to SMABA Not Accessible from ...

Poster rated this answer

Collapse -

SMABA Not Accessible from NT

by m_jamshaid In reply to SMABA Not Accessible from ...

This question was closed by the author

Back to Linux Forum
7 total posts (Page 1 of 1)  

Related Discussions

Operating Systems Forums