id="info"

Question

Locked

Sound driver problems

By D.H. Cesare ·
Did a complete new install of WinXP Home on a machine that previously had Vista. Always had sound before the new installation. The machine had an inexpensive set of HP speakers.

After the new XinXP installation there was no sound so I installed the Realtek AC 97 sound drivers and when that didn't help, I installed the HP audio drivers. That didn't help either.

Disconnected the little HP speakers that came with the machine and hooked up a set from a different machine, but that didn't work.

Went into the Device Manager, the Realtek was not listed and went into control panel to Sounds and it's all grayed out on the
general tab where the Realtek should be showing.

Don't know where to go from here.
What can I do to get this situation resolved?

Thank you.

This conversation is currently closed to new comments.

34 total posts (Page 1 of 4)   01 | 02 | 03 | 04   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

This is very common

by tintoman In reply to Sound driver problems

I advise people about this kind of problem every day, one of the reasons I often give not to downgrade from Vista to XP is that more often than not, when a computer is designed specifically for Vista, it is near on impossible to get drivers for all the hardware to work with XP.
The reality is there might not be any drivers in existence for your sound device. If it is a pc and the sound is integrated on the motherboard you could try the website of the motherboard manufacturer to get XP drivers for the sound. if it's a seperate sound card you could try the card manufacturer, otherwise your only option might be to fit a new xp type sound card

Collapse -

Upgrade

by D.H. Cesare In reply to This is very common

I consider XP an Upgrade from Vista. The machine I switched over is now working like a computer should work (excepte for the sound) where it was virtually useless with Vista.

I didn't look to see if the sound was integrated while I was over there, but I'm willing to bet that's the problem.

Thanx

Collapse -

Download a copy of

by ComputerCookie In reply to Sound driver problems

PC Wizard 2008 from CPUID http://www.cpuid.com/pcwizard.php

Run this on your computer and you will find out exactly what the sound device is.

After the program starts click on the Music/speaker icon, then do a search for that driver.

Any queries post back to this question.

Jeff

Collapse -

Cool Tool. Thanks <NT>

by CaptBilly1Eye In reply to Download a copy of

another addition to my bottomless toolbox.

Collapse -

The reason

by ComputerCookie In reply to Cool Tool. Thanks <NT>

I like it is because; when XP can't find the driver because it can't identify the device, PC Wizard does, great when want to upgrade an older computer.

You often find yourself pulling them out of an non-working computer and you don't know what the part is. Some of those serial nos are hard to find or on and Asian langauge webpage that has no translation

Collapse -

What makes you think that you have a Realtek Sound Device

by OH Smeg In reply to Sound driver problems

And even if you do what drivers did you use the ones that came with the computer when Vista was on it? If so they would be Vista Drivers not XP Drivers.

Look in Device Manager and see if there are any Unknown Devices these will be your Sound Device and you'll need to install XP drivers for them not Vista Drivers.

If you know what type of Sound Device you have you need to download the XP Drivers for it preferably from the maker but failing that if you do a Web Search for the Correct Drivers you will find a source if there are any available.

Col

Collapse -

No unknown devices

by D.H. Cesare In reply to What makes you think that ...

This is a complete new installation. Nothing was saved from Vista. So for all practical purposes, it was like a new HDD. Starting from scratch.

It's a one year old Presario. When I did the reformat and repartition it removed everything related to Vista, so when I installed XP it should have picked up the sound device and installed the drivers.

Collapse -

You cannot 'start from scratch' if the hardware was Vista-installed...

by OldER Mycroft In reply to No unknown devices

Because Vista hardware tends to have Vista-hardware, reinstalling XP over the top cannot deny the fact that the hardware was designed to be used with Vista.

Your problem is hardware-based.

Therefore an installation of XP is only effective at the software level.


<Edited for clarity>

Collapse -

clean installation

by D.H. Cesare In reply to You cannot 'start from sc ...

I did not install "over the top" of Vista. I formatted and repartitioned the HDD so as not to leave anything Vista behind.

Collapse -

But you HAVE left Vista behind - in the hardware ...

by OldER Mycroft In reply to clean installation

This is a complete new installation. Nothing was saved from Vista. So for all practical purposes, it was like a new HDD. Starting from scratch.

The ONLY thing here that is now new, is the empty hard drive. However for all practical purposes you still have a machine that was intended to be run with Vista. As such, some of the chips/hardware may not have XP drivers available for them.

It's a one year old Presario. When I did the reformat and repartition it removed everything related to Vista, so when I installed XP it should have picked up the sound device and installed the drivers.

Strictly speaking: it removed everything software-related to Vista, BUT you've still got a Vista-intended machine - you can't simply reformat that.

I'm with Smeg on this - what makes you think that you have properly identified the correct sound drivers?


<Edited for typos>

Back to Hardware Forum
34 total posts (Page 1 of 4)   01 | 02 | 03 | 04   Next

Hardware Forums