General discussion

Locked

Strange W2K DNS or is it IIS??

By Ah Beng ·
Hi,

I have a W2K server running DNS, IIS and Exchange 2K.
The DNS is AD/Private - 123.org. The public DNS is hosted by another ISP that is not local - 123.com.

Sending, receivng mails is fine. But not so when I browse the web pages that is stored in the IIS.
Internal users browsing the web page need to type : 123.org to see the web pages.
While eternal users type www.123.com they got no issue with the web page.
Internal users get an error "The page cannot be displayed" if they typewww.123.com

Is there any way to make it such that the Internal users can type www.123.com and get to access the web pages rather then typing a different URL each time they are in the office or at home.

The same issue with OWA for the Exchagne2K.

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

DNS Resolution

by eBob In reply to Strange W2K DNS or is it ...

If I read this correctly, your users cannot resolve the DNS name "www.123.com". There are a couple of ways to handle this.

1 - Configure your internal DNS so that if it cannot resolve a name, it passes the request on to the Internet. You do this by configuring the root to what should have been the default setting. (You will know when this is working when your internal users can resolve "www.techrepublic.com".)
2 - Configure your users to use 2 DNS servers in the Network Control Panel TCP/IPPanel (assuming Windoze). Although I have found that this does not always work properly.
3 - Keep a copy of the zone file for "123.com" on your internal DNS as well as the external. *** Foolproof *** The advantage of this is you can have "internal" services on 123.com that are maintained only in your internal zone file. Maybe "intranet.123.com" for your intranet, and not accessible from the outside world.

Collapse -

It was the NAT

by Ah Beng In reply to DNS Resolution

Hi eBob,

Thaks for the suggestion. Did try it out but it was still the same.
My colleague decide to do a study on the entire network and found the external router was doing the NAT instead of the firewall. He remove the NAT as we tested that even without the server plug in, we were able to get a ping reply as the router was replying instead of the exchange!
So we set the NAT on the firewall and reset the equiptments to clear all the caches and it works.

Thanks for the prompt reply.

Back to IT Employment Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums